A A A

Please consider registering
guest

Log In

Lost password?
Advanced Search

— Forum Scope —

  
 

— Match —

   

— Forum Options —

    

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Customized feature request
Oct 17, 2012
3:13 pm
simon martin
Forum Posts: 38
Member Since:
Sep 7, 2012
Offline

Not sure if this is feasible or not but I have a feature in mind that I’d like to inquire about. At stocktwits they have a feature where any stock symbol with a $ before it will automatically show an up to date chart (15 min delayed) when you hover your mouse over the symbol.

http://stocktwits.com/home#suggested

Is that possible for SP to implement somehow? I have the auto-updating charts in the threads themselves on each of the first posts, but I’d like it so while someone is scrolling down the thread titles in each forum, they can hover over the stock ticker in the title, and a small chart pops up just like it does at stocktwits.

Oct 17, 2012
3:20 pm
simon martin
Forum Posts: 38
Member Since:
Sep 7, 2012
Offline

If it’s possible and the price is right, I’m definitely willing to pay for the job.

Oct 17, 2012
4:32 pm
simon martin
Forum Posts: 38
Member Since:
Sep 7, 2012
Offline

Or how about someway to make it possible to add an img url to any given thread and if someone hover’s over the thread title, that image is shown? I’ve found a wordpress plugin that allows me to do what I’m looking for in the threads themselves, but I need that image to pop up somehow for each thread while in the topic view.

Oct 17, 2012
8:54 pm
Mr Papa
Simi Valley, CA

Forum Posts: 35487
Member Since:
Dec 10, 2006
Offline

confusing me a bit…  what do you mean by threads???  you say wp plugin that allows you to change titles in threads???  are you talking about forum topics here, or wp blog posts???

certainly any of these is possible with the simple press api and our filters…  filter post content and replace stock symbols with a link, when link clicked on open a popup with stock details…  of course, you would have to have a way to get the latest stock data/quotes from some service…

Oct 17, 2012
9:22 pm
simon martin
Forum Posts: 38
Member Since:
Sep 7, 2012
Offline

My apologies, let me give it another try. I have a WP plugin called hover and it’s set up to show a stock chart in a pop up window when the user mouses over a stock symbol. Scroll down to the second or third post and you can see the ticker EDIG has a line under it and if you mouse over it, you can see the stock chart for EDIG.

http://ichartpennystocks.com/f…..nk-sheets/

What I want to accomplish is have that same effect happen when you hover over the topic title (when viewing the topics list), so in this view you could hover over all of the titles and view the stock chart before you even enter the thread.

http://ichartpennystocks.com/f…..in-boards/

So if you click on the topic title I still want it to take you to the first page of the thread, but if you simply hover over it I want to see that stock chart image appear in place of where it normally says, “Browse the thread…..”. So instead of it saying that, I’d like to be able to put an image there (via url).

Oct 17, 2012
10:31 pm
simon martin
Forum Posts: 38
Member Since:
Sep 7, 2012
Offline

How can I get the WP Hover Plugin to look at those thread titles too (so it will show the popups in the thread title and not just in the topics)? Would that be an API filter? Am I on the right track with that?

Oct 17, 2012
11:08 pm
Mr Papa
Simi Valley, CA

Forum Posts: 35487
Member Since:
Dec 10, 2006
Offline

afraid I have no idea how that plugin works… does it hook into wp? how does it know how to do its thing… If you know that, we might be able to use our api to effect the same…

when we output the topic title in forum view, we fire the filter ‘sph_TopicIndexName’… so it would certainly be possible to ‘add’ stuff to the display to have the same effect, just need to know what they do…

obviously, the first time anyone has asked for anything like this, so we dont have direct support for anything like this… I dont even see a working example on your site for blog posts… did you post it earlier? (sorry, replying from email)…

Oct 17, 2012
11:35 pm
simon martin
Forum Posts: 38
Member Since:
Sep 7, 2012
Offline

The plugin is meant to display either text or an image, both in popup form, when you hover over certain words that you identify. For my site what I do is enter in stock tickers into the plugins database and link them each to their own dynamic chart image which I get from my charting program. So in the example I linked to you, EDIG was the stock ticker. Anytime someone hovered over the letters EDIG in my forum, it would display the image I had linked it to, which was the dynamic chart image (which updates upon refresh).

So after trying to research this and experiment, I stumbled upon filters. I see that the SP forum is displayed in the_content filter. I went through the php file for the plugin and found where they ran the add_filter and specified the_content, but I was trying to figure out where the topic titles output to. You answered that question just now so I added the same line with the sph_TopicIndexName filter, and it almost worked!

Now when I go look at the topic titles the key words that i’ve specified all indeed have the underline and look like the charts are going to pop up, but the message “Browse the thread…” still shows up instead. Adding that filter definitely worked, I just need to figure out how to disable that message so the chart can popup instead.

 

I apologize again for confusing the heck out of you, I’m learning as we go along and am slowly starting to put these pieces together. Thanks for your patience and help so far.

Oct 17, 2012
11:53 pm
simon martin
Forum Posts: 38
Member Since:
Sep 7, 2012
Offline

I figured out how to remove that message by deleting a little code in spForumView.php, but the chart still won’t popup. It looks like it should be working, a keyword will be underlined with a little dotted line and when you scroll over it the mouse pointer has a question mark next to it. Both of those are true but no dice. Any other filters I may need to add or any ideas what I can try?

Here is a link to the forum view and you can see all of the tickers are underlined.

http://ichartpennystocks.com/f…..in-boards/

Oct 18, 2012
7:56 am
Mr Papa
Simi Valley, CA

Forum Posts: 35487
Member Since:
Dec 10, 2006
Offline

odd, wouldnt have thought that is from the filter…   the_content filter for theme would have already been called on the entire forum page…

something is adding a acronym and span tags to the title, so agree that something is occurring…  but next step is to figure out exactly what the plugin wants to act on…  there is likely some js in listening mode for a specific html element…  within the forum, this element might be different because the tags are coming out in the middle of an html a tag…

need to figure out what sequence its looking for and then adjusting the output within that sp filter I gave you…  I think its the right place and filter…

Forum Timezone: America/New_York

Most Users Ever Online: 444

Currently Online: Yellow Swordfish, Ratgax
15 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Devices in use: Desktop (16), Phone (1)

Top Posters:

Radio: 1251

jim: 700

Conrad_Farlow: 680

Lee H: 606

Luffer: 536

Tal: 412

ovizii: 303

Carlos: 293

Member Stats:

Guest Posters: 387

Members: 7632

Moderators: 2

Admins: 2

Forum Stats:

Groups: 4

Forums: 12

Topics: 6631

Posts: 52433

Newest Members: David Blanchard, Lukasz Stepien, SHINICHI OHTA, Michael Gluska, Sjack Mies, santosh rathod, MKD, Beth Rumsey, xmaster, Breb Wilson

Moderators: Brandon C: 886, Ike: 44

Administrators: Yellow Swordfish: 31373, Mr Papa: 35487

Sponsors
Codex Pages
Keep In Touch