WordPress 5.9 & Simple:Press Forums

WordPress 5.9 introduced a new type of theme – the Full Site Editing theme where all components of the theme (including headers and footers) are blocks.

This is a radical change to WordPress themes.

But, the good news for Simple:Press is that we can still work with these new themes with a couple of minor adjustments to the Simple:Press settings.

These settings are:

  • Force The Strict Use of the WP API
  • Limit Forum Display to Within WP Loop
  • Bypass wp_head action complete requirement

All three settings are located at the bottom of the FORUM->INTEGRATION->PAGE & PERMALINK page.

All three items must be enabled!

Simple:Press Version 6.6.5

We’ve published an update to Simple:Press that will automatically turn on these flags if a Block Theme (FSE Theme) is enabled at the time the plugin is installed.

However, if you switch back to a classic theme you will need to turn off these options.

Or if you switch from a classic theme to a Block theme, you will need to turn on these options yourself.

Read Next

Did you find this article useful? Or do you use Simple:Press today?  If so, please support Simple:Press with a review on WordPress.org.  Every review goes a long way towards bringing other users on board!

Click here to review Simple:Press on wordpress.org

More From Simple:Press

Simple:Press Forum Gets A New Home

November 9, 2008

Welcome to the new home of the Simple:Press Forum Plugin for WordPress. With Version 4 about to be released on Beta, we thought we’d take this opportunity to build a dedicated site so we can focus on the future development and better support our users. Information and downloads for Version 3.1.x will remain at the…

Read More