A A A
Forum Scope


Match



Forum Options



Min search length: 3 characters / Max search length: 84 characters
Forum Login
Lost password?
plugins-topic
Widget: Recent Forum Posts wrong link
Avatar
Blaise
135 Posts
(Offline)
1
Oct 17, 2020 - 1:14 pm
Print

Hi,

2 days ago the widget “Recent Forum Posts” no longer has correct links to the forum posts. I display 5 forum posts and for each of these forum posts the link is the current page, not the actual forum post link.

So if the widget is on my homepage, anybody clicking on any of the 5 forum post is taken again to the home page where he already was.

I upgraded 2 days ago from SP 6.5 to 6.6.1 and Template and Widget plugin from 2.2.0 to 2.2.1.

I tried resetting my permalinks under both WP and Simple Press. I also tried flushing redis cache and page cache (even though the widget itself is never cached).

Thanks

Avatar
SP Community Support

280 Posts
(Offline)
2
Oct 17, 2020 - 2:48 pm
Print

Hi:

When you hover over the links and look at the link in the browser footer bar, does it show the link pointing to the current page?  Or does it show the proper URL for the link ?

Whenever I hear about items like this it’s almost always a caching issue.  Did you clear your caches after the upgrade?

Also, please remember that WP can have multiple caching levels:

– Your host can have a cache that you might or might now have access to

– There can be a page caching plugin

– You might have an object cache as part of the hosts’ WP installation

– If you’re using a CDN such as CloudFlare it has a cache.

– Your browser has a cache as well.

– If you’re using certain themes (especially page builders) they tend to build caches as well though they shouldn’t be caching anything from the forum.

So you’ll need to make sure all those caches are cleared out.

Thanks.

Building out your membership site can be a lot of work. Easy Membership Sites has pre-configured all the Simple:Press plugins and tools you need to build a complete membership site in a fraction of the usual time. Check them out: Easy Membership Sites

Avatar
Blaise
135 Posts
(Offline)
3
Oct 23, 2020 - 10:38 am
Print

Hi,

Thanks for the answer. I am pretty savvy with caches and indeed agree with you that often caches are the culprit. But not here.

After a few days searching I finally found the “bug” (?).

If in the widget settings I put “all” under “Scope of Link” then I get the bug mentionned above. If however I put “forum” then all works. Previously it was set to “all” and worked perfectly.

Not sure if this is a bug but appears to me to be one 🙂

Avatar
Blaise
135 Posts
(Offline)
4
Oct 23, 2020 - 10:49 am
Print

Hi again,

I think I found a related bug.

If under “display order” I have ATFU and Scope of Link “forum” then:

– Clicking on the forum link beings to the topic

– Clicking on the topic link brings to the forum

 

If “display order” is set to AFTU then it works correctly (but this is not what I want)

Forum Timezone: America/New_York
All RSSShow Stats
Administrators: Blues Dancer, Simple Press, SP Community Support
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 630
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Newest Members:
James Smith
Martin Brothers
Arti Singh
Abdulaziz alghthbar
Tim Castillo
Kaspalita Thompson
Martin Kolář
Forum Stats:
Groups: 7
Forums: 17
Topics: 10059
Posts: 79348

 

Member Stats:
Guest Posters: 607
Members: 16900
Moderators: 0
Admins: 3

Most Users Ever Online
499
Currently Online
Guest(s)
24
Currently Browsing this Page

1 Guest(s)