Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
general-topic
5.0 Testing Requirements
Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Jun 22, 2011 - 8:17 am

When Simple:Press 5.0 releases, it will require WordPress version 3.2. 

This is primarily due to matching php and mysql version 5 requirements… php needs to be at least 5.2.4 and mysql needs to be at least 5.0.15…

WordPress version 3.2 is currently in release candidate so its pretty stable and we have been using it for months.  We have not tested 5.0 on version 3.1.3 but it should work.

Avatar
Shari
Chicagoland, IL USA
Member
Free Members
sp_UserOfflineSmall Offline
Sep 3, 2011 - 11:10 am

Here are my versions, the one I'm unsure of is the MySQL

  • Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1
  • MySQL client version: mysqlnd 5.0.7-dev - 091210 - $Revision: 304625 $

I know some versions is are now being read as whole number ie 15 would be higher the 7. I'm not sure how MySQL is set, so do I need to upgrade?

Shari uneedstuff.com | My Blog | Making Time for you!

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Sep 3, 2011 - 11:23 am

That is a topic I have been meaning to talk with Andy about...  Not sure how 5.0.15 got selected...  WP has established a min version of 5.0 so not sure how we got out of line...

but as currently coded, you would need to upgrade... but will get back with you later today...

Avatar
Shari
Chicagoland, IL USA
Member
Free Members
sp_UserOfflineSmall Offline
Sep 3, 2011 - 11:36 am

Ok based on this image. .7 is newer then .15 I wish people would decide how they are going to version stuff and stick with it [Image Can Not Be Found]

http://upload.wikimedia.org/wi.....8563da.png

Shari uneedstuff.com | My Blog | Making Time for you!

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Sep 3, 2011 - 12:30 pm

dont confuse 5.0.7 with 5.0.70

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Sep 3, 2011 - 1:26 pm

according to mysql release notes (http://lists.mysql.com/announce/326) 5.0.15 was the first, official production release of 5.0...  so anything prior, like your 5.0.7 was pre-release (ie alpha, beta, dev, etc)...  

so yeah, you really should upgrade to a formal release...  and current one...  5.0.15 was released on October 24, 2005...

but we are still evaluating if we want to simplify the version check to any 5.0 version...

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Sep 3, 2011 - 2:26 pm

fyi. I have committed  a change to make the version check for mysql to be 5.0 to match wp...

Avatar
Shari
Chicagoland, IL USA
Member
Free Members
sp_UserOfflineSmall Offline
Sep 3, 2011 - 2:35 pm

Mr Papa said:

dont confuse 5.0.7 with 5.0.70

aaarrrggg!!! LOL I'll be updating.

Shari uneedstuff.com | My Blog | Making Time for you!

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Sep 3, 2011 - 2:42 pm

wink

Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 649
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 618
Members: 17348
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10120
Posts: 79607