Support Forum

500 error after upgrade when trying to post

25 Answers

New Answer

ST Steve20
Steve20
Member

I’m using All In One WP Security plugin.   I’m using WPRocket just for caching not for minimizing scripts.

YS Yellow Swordfish
Yellow Swordfish
Member

Is there a chance you could turn the caching off briefly? It would discount it as a culprit and it might be having a problem with nonces. Rocket is pretty difficult to get set up right I do know that…

ST Steve20
Steve20
Member

Yes,  I tried that before and it it didn’t change the error.   I tried it again just now and again nothing changed.   I can give someone access to the forum if that would help but I would rather not post a username and password on the forum………….Let me know.

YS Yellow Swordfish
Yellow Swordfish
Member

Well – 500 errors are hard to track down from the actual website – you would normally need to locate the issue on the server – but we are more than willing to take a look of course. And you never know!

Please PM credentials to both myself, to ‘Mr Papa‘ and to ‘Ike‘. Please include in the PM a link to your site, a link to this thread and brief reminder of the problem. And one of us will take a look for you.

YS Yellow Swordfish
Yellow Swordfish
Member

Actually – if you can make that account an SP Admin user it might help. We may need to look at the error log in the toolbox.

YS Yellow Swordfish
Yellow Swordfish
Member

Not sure how you get into the admin but let;s start with a question.

I note you have our file uploader active, If you deactivate that does it allow the post to go through?

ST Steve20
Steve20
Member

Holy Cow!!  That fixed it!   How and why?  Is there something wrong with that plugin?  Thanks so much!

MP Mr Papa
Mr Papa
Member

No, not that we know of…  Not sure why @yellow-swordfish was going for there, so will have to wait for AM when he returns…

ST Steve20
Steve20
Member

Mr Papa said
No, not that we know of…  Not sure why @yellow-swordfish was going for there, so will have to wait for AM when he returns…  

Maybe it has to do with this thread:

https://simple-press.com/support-forum/sp5-plugin-topics/unable-to-post-replies-or-new-topics-after-upgrade/page-2/#p161705

MP Mr Papa
Mr Papa
Member

Well that is not an issue with the plugin.  But perhaps your server php configuration does not have mbstring enabled.  WP uses as well and it’s standard for most php installs. Worth checking with your host.

YS Yellow Swordfish
Yellow Swordfish
Member

Absolutely. As I said in the other thread, WordPress used to test for the existence of the mbstring functions but they appear to be starting not to do that. MBString (f you do no t know this means multi-byte and is required by many languages, for example) really should be standard and most commonly is. It does suggest your host is lagging behind the filed a bit and should be encouraged to catch up! Please do let us know if they happily include it for you.