Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
general-topic
Edit Posts: Access denied - you do not have permission to view this page
Avatar
erin peloquin
Member

Silver Members
sp_UserOfflineSmall Offline
Dec 28, 2017 - 11:53 am

Each time my customers and I try to edit posts, we get this message:

Access denied - you do not have permission to view this page

It looks as if the user is logged out. This happens both on my admin account and on my test user account.

Where should I start troubleshooting? I do have the ability to edit posts forever box checked in the permissions settings.

thanks!

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Dec 28, 2017 - 12:42 pm

where and how are you trying to edit posts?  are you using forum tools or the edit button in the topic view, post row?   I assume you mean forum posts and not blog posts?

no caching plugin active on the forum pages?

do you have link to the site in question?

not likely the issue, but might go to forum - toolbox - housekeeping and reset the auths cache...

Avatar
erin peloquin
Member

Silver Members
sp_UserOfflineSmall Offline
Dec 28, 2017 - 1:59 pm

Yes, I'm using the Edit button in the topic view. And yes, forum posts for sure.

Here is a link to the forum. Do you need to be able to login?

No caching plugin.

Auths cache reset.

Same issue. It looks like no one has access to the edit page. The URL stays the same before and after clicking edit. Should it change after clicking the Edit button?

Thanks!

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Dec 28, 2017 - 3:29 pm

the url is the same?  doesnt sound quite right...  or at least there should be some query args or POSTed args...  

any chance your server is running mod_security?  more false positives than true positives... could be stripping some of the 'edit' args...

Avatar
erin peloquin
Member

Silver Members
sp_UserOfflineSmall Offline
Dec 28, 2017 - 4:23 pm

Args? I don't speak pirate! 🙂

But no, the url definitely stays the same. I'd expect to see something funky like #edit. Should I check with my host on the mod_security? I don't have a clue whether I'm running it or not.

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Dec 28, 2017 - 4:33 pm

Yes please - checking for mod-security is the best and first place to look at. if your host confirms it is being used then usually they will disable it for you for testing and then can white-list the pattern of the url so things work properly,.

andy-signature.png
YELLOW
SWORDFISH
Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 649
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 618
Members: 17356
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10122
Posts: 79610