Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
general-topic
Error when reading forum posts
Avatar
Basil Jackson
Member
sp_UserOfflineSmall Offline
Mar 9, 2017 - 2:07 am

When I try to reading a forum post and error appears at the top of the forum topic.

-----ERROR-----
Warning: in_array() expects parameter 2 to be array, string given in /home3/re552358/public_html/itrack/wp-content/plugins/simple-press/forum/content/classes/sp-topic-view-class.php on line 304

-----END-----

Also see attachment

forum-screenshot.jpgImage Enlarger

TIA,
Basil

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Mar 9, 2017 - 4:14 am

This is a notice that should disappear quickly after your users have visited. Actually we are a bit unsure why it appears at all as logic clearly says it should not. But it is fixed in the forthcoming 5.7.4 to make sure it doesn't get triggered again.

What is actually far more important is the question why your website is configured to display such messages to the screen in the first place. Any host that sets up your php to show messages like this is failing in their responsibility as it should not happen. First and foremost it is a security risk as it exposes the complete path to your server. It is also, of course, disruptive and ugly.

Assuming you yourself have not turned screen display on for this - or do not have the WP Debug mode turned on then you need to flag this with your hosting support ASAP and tell them to turn off error messaging to the display - as it should be off for any live website.

But we do apologise for the issue in the first place. It is harmless by the way.

andy-signature.png
YELLOW
SWORDFISH
Avatar
Basil Jackson
Member
sp_UserOfflineSmall Offline
Mar 9, 2017 - 6:42 pm

Yellow Swordfish,

I just checked and I can confirm your statement that this will not appear once a user adds a post. No error is being displayed now.

Thanks for the tip on displaying errors. I will certainly look into this as well.

Thank You,
Basil

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Mar 10, 2017 - 12:13 am

just let us know...

Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 649
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 616
Members: 17348
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10118
Posts: 79603