Support Forum

Forum not set – Unable to Create Post

UN
Unknown
Member

Hello

I recently received the following error message while attempting to post.

\”Forum not set – Unable to Create Post\”

 

I’ve checked the error logs and nothing related is popping up. 

 

I’ve also noticed, that this error message is only occuring if I attempt to Copy and Paste into the text field from an exterior source ie website/notepad etc. If I directly type in, it posts just fine. I looked through the other post related to this issue but haven’t found anything to solve it.

I am running

Version: 5.0.1    Build:  8048

Author Avatars List (1.4.1)
Better WordPress Minify (1.0.10)
Capability Manager (1.3.2)
Cimy User Extra Fields (2.3.7)
Dashboard Editor (1.1)
Event Calendar (3.1.4)
Event Calendar Widget (3.1.4)
My Link Order (3.1.4)
NextGEN Gallery (1.9.3)
Pierre’s Wordspew (6.1)
Redirector (2.0)
Sidebar Login (2.3.4)
Simple:Press (5.0.1)
User Role Editor (3.5.1)
WP-Polls (2.62)
WP Private Messages (1.0.1)
WP Widget Cache (0.25.4)


Could you please help me?

14 Answers

New Answer

UN
Unknown
Member

Quick update. It’s not copy and pasting text that causes the issue. It’s copy and pasting URL’s that will cause that issue for creating a post. If I try to Edit a post, the post will simply refuse to edit.

YS Yellow Swordfish
Yellow Swordfish
Member

Well that’s a new one on me!
Will probably need to take this one step at a time.
Is this true of ANY content you try and paste in or has this only happened with the same content?

UN
Unknown
Member

Yes, I am duplicating this problem creating a post with ANY link from any site, with http:// inserted. I am also currently using Plain Text as default (current) editor. 

Wonder if this has anything to do with? 

YS Yellow Swordfish
Yellow Swordfish
Member

No that wont be an issue.
Could we have a link to your forum page. Might be able to spot something – you never know.

YS Yellow Swordfish
Yellow Swordfish
Member

well there are some script issues with your site which may be a factor. I kind of doubt it to be honest but these can get in the way of all sorts of operations.

Yoir site – theme or another plugin? is loading an incorrect version of the jQuery UI core library (calling it ‘personalised’ whatever that means or contains?) The problem is explianed here: http://codex.simple-press.com/codex/faq/troubleshooting/what-is-this-jquery-conflict/

I would also suggest you turn off the ‘minify’ tool. The vast majoroty of the scripts you are loading are compressed anyway so it is unnecessary and meaningless.

UN
Unknown
Member

I removed the .js and line of php code requiring the personalized script you mentioned. I also removed Minify, but alas no changes.

UN
Unknown
Member

I also tried turning off the theme and switching to others, I still get the same blank page with error message. Doesn’t seem to be theme related. 

MP Mr Papa
Mr Papa
Member

errors look cleared up… but we cannot test since guests cannot post…

is your server by any chance running mod_security or other module that might be limiting the passing of POST data?

UN
Unknown
Member

Yes the host is using mod_security. Is there any alternatives to disabling mod security?

UN
Unknown
Member

Hey guys,

I had my provide disable mod_security. It seems that the problem is fixed and the POST variables were indeed being blocked by modsecurity. I hope there is an alternate solution so I can re-enable it again some time.

YS Yellow Swordfish
Yellow Swordfish
Member

That rather depends on your host. In my limited experience most hosts are aware that mod_security is the bane of every developers life and – at the end of the day – a right pain in the backside for most people. And they are usually willing to whitelist out the rules they have imposed that breaks a users website. So if they are prepared to do that then you have the best of both worlds.

UN
Unknown
Member

Yellow Swordfish said 

That rather depends on your host. In my limited experience most hosts are aware that mod_security is the bane of every developers life and – at the end of the day – a right pain in the backside for most people. And they are usually willing to whitelist out the rules they have imposed that breaks a users website. So if they are prepared to do that then you have the best of both worlds.

 

Makes sense. Thanks for your help guys! Cheers 🙂

YS Yellow Swordfish
Yellow Swordfish
Member

You’re welcome. Glad we resolved it in the end.