Support Forum

Various issues on uploader and profile edit after upgrade

19 Answers

New Answer

YE Yehonal
Yehonal
Member

If you note i’ve linked you the exact line where default filters add this action:

add_action( ‘wp_default_scripts‘, ‘wp_default_scripts‘ );

this action call the wp_default_scripts even if you’re in frontend, loading all that scripts and css including plupload and jqueryui

 

in fact if i comment out that line the frontend doesn’t work anymore with a lot of missing library errors

 

Dunno how’s it possible

YE Yehonal
Yehonal
Member

The fact is that i’ve any errors both in browser console and in apache errors log….just a null popup :-/ i’m very confused

YS Yellow Swordfish
Yellow Swordfish
Member

I am not going to argue any further about whether plupload is loaded by WP on the front end or not. I simply point out that it is a point of conflict in your website that may well have a negative effect on uploading within the forum.

The double loading of the jQuery UI library is something that can have negative effects on things as I have already stated. It is to to you whether you deal with this potential issue or not.

So lets just concentrate ion the profile issue.

the inly time I have seen this behaviour it was caused by a WP plugin that aded profile features. Do you have any such plugins active? In fact ANYTHING ay all that may effect profile data?

YE Yehonal
Yehonal
Member

I’ve disabled all plugins related to profile, don’t know if i’m missing something but i’m tring to debugging it.

Javascript doesn’t show any errors and even my apache error log. So i think there’s some strange behaviour with sessions/cookie and the ajax call fail

 

take a look at this screenshot

sperror.JPG

 

both ajax calls return a null response (even if success) but i’ve tried to load that url you can see in .load() normally in a browser  taband it returns the signature string….so it seems that the .load() and .ajaxForm() have problem with sessions ( ? :confused: )

MP Mr Papa
Mr Papa
Member

they shouldnt have and dont see how they would…  but perhaps something on your site is blocking ajax requests… something like mod_security which has been known to run amok like that… any chance you have mod_security or other security app running?