Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
plugins-topic
Post Ratings Style
Avatar
Michael Walden
Member
Free Members
sp_UserOfflineSmall Offline
Apr 28, 2018 - 7:48 am

 Hello!

I attempted to change the post ratings style from stars to thumbs up/thumbs down. I was not prompted to confirm the change nor did it save the change in the options panel.

Thank you!

“I must stop him from being one of those who call themselves good because they have no claws.” ― Irvin D. Yalom, When Nietzsche Wept

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Apr 28, 2018 - 11:49 am

Are changes in the admin panels generally being saved OK? In other words is this specific to the Post Rating option or part of a larger issue?

andy-signature.png
YELLOW
SWORDFISH
Avatar
Michael Walden
Member
Free Members
sp_UserOfflineSmall Offline
Apr 28, 2018 - 1:25 pm

I haven't noticed an issue anywhere else. I had to add some file type extensions to the file uploader plugin and that worked fine. Other than that I haven't needed to make many option changes recently.

“I must stop him from being one of those who call themselves good because they have no claws.” ― Irvin D. Yalom, When Nietzsche Wept

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Apr 29, 2018 - 2:30 am

Sorry for the delay.

We are going to have to ask you to check in your web console for script errors. Open the admin  panel and then try the operations again and see if anything gets reported.

If you have no experience with the console then this FAQ should help point the way: https://simple-press.com/docum.....r-console/

andy-signature.png
YELLOW
SWORDFISH
Avatar
Michael Walden
Member
Free Members
sp_UserOfflineSmall Offline
Apr 29, 2018 - 7:06 pm

This is all Greek to me, but it is what came up in the console. I just noticed too that even though the stars are still showing as the rating system on the display, they do not work anymore. Clicking on any star results in nothing as they no longer are a link.

 

Uncaught TypeError: Cannot read property 'split' of undefined
at HTMLDocument. (admin.php?page=simple-press%2Fadmin%2Fpanel-options%2Fspa-options.php&tab=display:6895)
at HTMLDocument.dispatch (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3)
at HTMLDocument.r.handle (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3)
at Object.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3)
at Object.a.event.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:9)
at y (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:4)
at XMLHttpRequest.c (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:4)
VM415:1

Uncaught TypeError: Cannot read property 'style' of null
at spjToggleLayer (eval at (spa-admin.js?ver=4.9.5:1), :1:1588)
at HTMLInputElement.eval (eval at (spa-admin-events.js?ver=4.9.5:1), :1:139)
at HTMLInputElement.dispatch (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3)
at HTMLInputElement.r.handle (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3)
spjToggleLayer @ VM415:1
(anonymous) @ VM417:1
dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3
r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3
VM415:1

Uncaught TypeError: Cannot read property 'style' of null
at spjToggleLayer (eval at (spa-admin.js?ver=4.9.5:1), :1:1588)
at HTMLInputElement.eval (eval at (sp-subscriptions-admin.js?ver=4.9.5:1), :1:3273)
at HTMLDivElement.dispatch (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3)
at HTMLDivElement.r.handle (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3)
spjToggleLayer @ VM415:1
(anonymous) @ VM420:1
dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3
r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jquery-ui-cor&load[]=e,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9.5:3

“I must stop him from being one of those who call themselves good because they have no claws.” ― Irvin D. Yalom, When Nietzsche Wept

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Apr 30, 2018 - 3:35 am

Yes - that's all a bit dense isn't it!

Try this first.

  1. Go to the forum admin > toolbox > housekeeping and click on the two tasks to reset combined CSS/JS caches - one at time.
  2. Clear your browser cache to make sure it is nit holding ion to anything significant.

If that does not make any difference we may need to ask if we can access the SP Admin to take a closer look.

andy-signature.png
YELLOW
SWORDFISH
Avatar
Michael Walden
Member
Free Members
sp_UserOfflineSmall Offline
Apr 30, 2018 - 6:36 am

I was so hopeful, as I had forgotten those options, but no, it didn't help 🙁

“I must stop him from being one of those who call themselves good because they have no claws.” ― Irvin D. Yalom, When Nietzsche Wept

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Apr 30, 2018 - 8:52 am

Shame - but it was worth a try!

Would it be possible to have a forum Admin account so that we can take a look at the generated source and look at the generated urls for the AJAX calls. Is this possible?

If so – could you please create an SP Admin account so that we can log in and see the forum behaviour. Please send a PM to both myself (Yellow Swordfish) and Mr Papa with credentials.

It helps if you can include links to not just your forum but also to this topic so we can get to it quickly to re-read what has been said. A brief reminder of the problem is also very helpful.

andy-signature.png
YELLOW
SWORDFISH
Avatar
Michael Walden
Member
Free Members
sp_UserOfflineSmall Offline
Apr 30, 2018 - 11:03 am

Done. Botched the first message, that's the kind of day I'm having haha! Second message has all the details

“I must stop him from being one of those who call themselves good because they have no claws.” ― Irvin D. Yalom, When Nietzsche Wept

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Apr 30, 2018 - 3:21 pm

OK. Thanks. I am seeing an odd error so I will need to confer

andy-signature.png
YELLOW
SWORDFISH
Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 649
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 618
Members: 17348
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10120
Posts: 79605