Support Forum

Default theme lost style

27 Answers

New Answer

RC Roberto Ciccolella
Roberto Ciccolella
Member

UPDATE at 3:02PM

This is the dev server link: http://wp-web.co.uk/ciaoweb-2012/forum/

You can login and to what you want even break it since is just a copy in my dev server. If we find the solution at the issue will apply it to the live site.

Thanks again

RC Roberto Ciccolella
Roberto Ciccolella
Member

Further Update 3:40PM

Using the Chrome Inspector Console I have this error message:

Failed to load resource: the server responded with a status of 500 (Internal Server Error)

http://wp-web.co.uk/ciaoweb-2012/wp-content/sp-resources/forum-themes/default/styles/default.php?color=wintery-blue

YS Yellow Swordfish
Yellow Swordfish
Member

OK – on to something here I think.
Can you open the default.php file in the SP theme folder. At the top there are two lines of code that start with the word ‘header’. Can you copy and paste them here for me please?

RC Roberto Ciccolella
Roberto Ciccolella
Member

Here they are:

header(“Content-Type: text/css; charset: utf-8”);
header(“Expires: “.gmdate(‘D, d M Y H:i:s’, (time()+900)) . ” GMT”);

Thanks

 

YS Yellow Swordfish
Yellow Swordfish
Member

Which looks correct.

However – according to httpFox – the server is actually looking for a Type of ‘text/problem-with-post-edit-buttontml’ NOT a Type of ‘text/css’. And it seems to me that having not found a file of type html the server is responding with a 500 error.

Now I am no expert in this arena but I have checked with several sites and Simple:Press and in al cases text/css is what the server is asked for and what it responds with except – for yours. And this is on your dev server.

Someone out there knows the reason and the answer for this but I am afraid it isn’t me! Although I will do some Googling after my dinner….

RC Roberto Ciccolella
Roberto Ciccolella
Member

Thanks Yellow,

Have a nice dinner anyway…

 

 

YS Yellow Swordfish
Yellow Swordfish
Member

Actually I WOULD ask your host that question anyway…

MP Mr Papa
Mr Papa
Member

my guess is your server is no set to recognize a mime type of css for files with php extension… check with your host…

another good test would be to try the css-only sp theme…  bet it works… ;)

RC Roberto Ciccolella
Roberto Ciccolella
Member

Hello,

Good news! Sorted!

I had a chat with Hostgator Support and they discovered that it was just a setting permission altered, for some reasons that I don’t know the Default theme folder was setup at 777… and this CHMOD permission was causing the issue, in the live site I have changed the folder permission to 755 and now the theme is working again.

I have no idea how and when the folder permissions were changed.

Anyway thanks again for your support.

 

 

 

YS Yellow Swordfish
Yellow Swordfish
Member

Excellent news. Actually you said in post 4 of this topic you had Changed all the folders to 777 and Steve said in the next post that this could sometimes stop things from working. Some hosts will not allow 777 for some types of operation.

But the good news is things are back to normal…

RC Roberto Ciccolella
Roberto Ciccolella
Member

You are right and  I apologize that I have forgot that I changed the permission setting, but I remember that I have reverted the permission ton 755 for wp-content, never mind is over now.

Thanks