Support Forum

Theme css problem after update ( 1.0.3 )

UN
Unknown
Member

Hi there, an hour ago, I saw the update in my WordPress panel for Simple Press v5. I used auto update via FTP and updated. Downloaded new v 1.0.3 themes but still forum cant read the css.

 

When I open the source of the page, everything is fine but when I click to see the source of css file. WordPress gives me 404 not found error. But I double checked the file, its there!!

 

http://www.unibu.net/forum here is my forum adress.

 

Wp version 3.3

SP version 5

 

Thanx

6 Answers

New Answer

MP Mr Papa
Mr Papa
Member

multiple things…

first, the page loading cannot load the default.php theme file… as you said, it appears to be there as I can see it my browser…  but that only says it exists… it wont load in the browser… this leads me to think that the permissions have gotten messed up on the file…

can you look your server and see what the permissions and owner are for the wp-content, sp-resources, forum-themes and default directories?

second, you have a bunch of js errors on your site…  your wp theme is doing bad things and loading jquery and jquery ui from its own supplied js…  this will be in conflict with the jquery and jquery ui shipped with wp and expected by wp and plugins…

UN
Unknown
Member

owner group says : 533-531

 

it was working perfectly before the update, but I used WordPress auto update with FTP information. Maybe it messed up things.Or maybe the theme I’ll try it with a different wp theme then will write here back.

MP Mr Papa
Mr Papa
Member

so owner is identical for all those directories??? and the permissions?

wondering if using your ftp gives you a different user than say the web user…

UN
Unknown
Member

well I tried default theme for Js errors but still not working.

 

So I checked all the server owner numbers, all the same.

Files are 755 and content dir is writable.

 

but I found this on error logs and couldnt understand

 [Wed Dec 21 20:05:53 2011] [error] [client xxx.xx.xxx.xxx] SoftException in Application.cpp:601: Directory “/problem-with-post-edit-buttonome/unibu/public_html/wp-content/sp-resources/forum-themes” is writeable by group, referer: http://www.unibu.net/forum

[Wed Dec 21 20:05:53 2011] [error] [client xxx.xx.xxx.xxx] SoftException in Application.cpp:601: Directory “/problem-with-post-edit-buttonome/unibu/public_html/wp-content/sp-resources/forum-themes” is writeable by group, referer: http://www.unibu.net/forum

 

In every forum load it logs errors like this. I tried changing permissions from 777 to 755 but still the same :/

UN
Unknown
Member

Oh ok, I fixed it 🙂 my wp-content folder’s permission was 777, so it caused error I guess. I changed it to 755 and now theme working.

 

Thanx for help

MP Mr Papa
Mr Papa
Member

good to hear. not sure why, but can say you dont really want 0777 on folders generally…

and thanks for the update… have noted it in case anyone else has similar problems…