Support Forum

404 After Install

CA carnold
carnold
Member

Fresh install of WP 3.3.1 and a fresh install of SimplePress 5. I activated SP and installed from the plugins page of WP. When i view the blog, i see 3 pages added, 2 Discussions and 1 Forum. All 3 give:

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.

Error 404

I have updated the permalinks in SP but still get a 404. Can anyone help me get this worked out?

16 Answers

New Answer

MP Mr Papa
Mr Papa
Member

Sorry, I am not sure what you are saying…  added 3 pages????  all the forum content appears on single wp page created at install…

This appears to be:  http://teknerds.net/blog?page_id=63

on your site… not really sure why you are using the ugly default wp permalinks, but thats your call…

I see 5 groups and numerous forums and subforums…  links to all are working…

I do not see any topics and as I guest, I cannot try to create one…

CA carnold
carnold
Member

Yes, 3 pages. I have deleted the 2 discussions and kept the forum page. The reason it is ugly permalinks is because it only works on the default WP permalink. Any other result in a 404. Are the icons next to the forum the default icons? Cause they look like they are missing. Also, on the default permalink, WP links are all wonky. I logout using the WP admin panel and it points to http://teknerds.net/blog/forum which is the permalink structure i would like to use but currently am not. Seems to me something happened and the install of SP did not go right. I did get some error about sp-resources.part1.zip and having to copy and extract to the new folder, which i did and then update the storage locations and they all check out. Puzzled……

YS Yellow Swordfish
Yellow Swordfish
Member

SP creates one single page when it is installed named ‘Forum’. It does not create any others and in particular not one called ‘Discussion’ so that or those came from somewhere else. Another forum plugin maybe?

What is the ‘/blog/’ part of the your preferred URL? What does it represent? Does this mean the ‘Forum’ page is a sub-page of ‘Blog’?

CA carnold
carnold
Member

This WP site was a fresh install and without another forum plugins. I only had Akismet, SEOPressor and All in One SEOPack for plugins. Teknerds.net is the main non-WP site and the /blog part is the WP site. So the /blog represents where the WP site is installed.

MP Mr Papa
Mr Papa
Member

so what is the problem?  all the links there I tried work for me…  oh wait, that’s why you have default permalinks on?

what is seopressor and what does it do?

hard to tell much with it working though…

CA carnold
carnold
Member

Yea, working with default permalinks and you wont see much when its not working except a 404.

I deleted/uninstalled SP which deleted the SP tables from the DB. I then deleted the extracted files/folders in the wp-content folder. Extracted the zip file and copied back to wp-content/plugins. Inside the plugins panel of WP, activated then installed SP. Here is what i received:

YOU WILL NEED TO PERFORM THE FOLLOWING TASKS TO ALLOW SIMPLE:PRESS TO WORK CORRECTLY

[Resources part 1 file failed to copy] – You will need to manually copy and extract the file ‘/simple-press/sp-startup/install/sp-resources-install-part1.zip’ to the new folder


[Resources part 2 file failed to copy] – You will need to manually copy and extract the file ‘/simple-press/sp-startup/install/sp-resources-install-part2.zip’ to the new folder


[Resources part 2 file failed to unzip] – You will need to manually unzip the file ‘sp-resources-install-part1.zip’ in the new folder


[Resources part 2 file failed to unzip] – You will need to manually unzip the file ‘sp-resources-install-part2.zip’ in the new folder

Is this normal? The permissions on the WP plugins folder is can view and modify for all groups (just to see if this works). Feel free to see a 404 when you click on forum (month and name permalinks now).

MP Mr Papa
Mr Papa
Member

it is normal if the server settings are such that the web user (ie our plugin) or php configuration cannot create the directories…

so did you manually go do all the steps listed there?

CA carnold
carnold
Member

Yes. We seem to be getting nowhere! Heres what i have done:

-deleted the sp_* tables from the DB and completely uninstalled SP->reinstalled and have same problem.

-renamed htaccess file and had WP create me a new one->same problem.

-create just a WP page and click on that page and get 404.

Any other ideas?

YS Yellow Swordfish
Yellow Swordfish
Member

“create just a WP page and click on that page and get 404”
Do you mean just any WP page – i.e., not forum related? If so then this is probably useful…

YS Yellow Swordfish
Yellow Swordfish
Member

So actually it is your whole WordPress site that is getting 404;s NOT just SP.
Did WP write the .htaccess file when you changed permalinks?

CA carnold
carnold
Member

Yes, i have verified htaccess is getting written. I have also posted in WP forums and no one has answered:

http://wordpress.org/support/topic/404-on-any-page-creation?replies=2

Hoping someone here can help

CA carnold
carnold
Member

Here are the logs when using SP and updating permalinks:

[Sun Mar 04 16:56:55 2012] [error] [client 192.168.123.165] ALERT – script tried to increase memory_limit to 268435456 bytes which is above the allowed value (attacker ‘192.168.123.165’, file ‘/srv/www/problem-with-post-edit-buttontdocs/sites/teknerds/blog/wp-admin/admin.php’, line 109), referer: http://teknerds.net/blog/wp-admin/admin.php?page=simple-press/admin/panel-forums/spa-forums.php

[Sun Mar 04 16:57:00 2012] [error] [client 192.168.123.165] ALERT – script tried to increase memory_limit to 268435456 bytes which is above the allowed value (attacker ‘192.168.123.165’, file ‘/srv/www/problem-with-post-edit-buttontdocs/sites/teknerds/blog/wp-admin/admin.php’, line 109), referer: http://teknerds.net/blog/wp-admin/admin.php?page=simple-press/admin/panel-integration/spa-integration.php

Here is the log when i edit the forum page in WP:

[Sun Mar 04 16:57:36 2012] [error] [client 192.168.123.165] File does not exist: /srv/www/problem-with-post-edit-buttontdocs/sites/teknerds/blog/forum, referer: http://teknerds.net/blog/wp-admin/post.php?post=67&action=edit

Here is when i access said forum page:

[Sun Mar 04 17:03:28 2012] [error] [client 74.125.156.80] File does not exist: /srv/www/problem-with-post-edit-buttontdocs/sites/teknerds/blog

Mod_rewrite is loaded and on.

MP Mr Papa
Mr Papa
Member

so, the first says you are running out of php memory… you might want to try increasing yours… our faq has a quick and easy way to do that… but not likely the cause…

out of curiosity, when you installed wp in the subdir, did you follow all the wp instructions including editing the one wp core file?

http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory