Is it possible that my installation of simple-press is causing 404 errors to links on my menu bar. Ever since I installed it I have to go to my permalink settings at least twice a day and hit save to make everything come back to normal.
Support Forum
No it shouldn’t have any adverse effect on urls. SP will have established it’s rewrite rules and added them to the WP rewrite rule list (held in the database) when it was first activated, Shouldnlt have to do it again after that.
We did have another user recently who was having problems with urls created by the Woo Commerce plugin after SP was installed. Do you have that on your site? Or do you have any other plugins that might be creating their own rules – a little like SP does with all it’s pages being displayed on a single WP page item?
I dont use any woo related themes or plugins. Let me think about any plugins that are displaying everything on one page like you said. Thanks for your help
I cant seem to find any plugins that might be causing this. All I know is that ever since in installed the SPF i been getting at least 2 404 errors a day where I have to go and hit save in the permalinks section to get it to work again.
So after you update the site permalinks – I assume in the WP admin > settings > permalinks – are you then following it up by updating the forum permalinks on the WP Integration panel of the forum admin?
The way this works is that Wp maintains a record in the Options table called ‘rewrite rules’. When a plugin (such as SP) needs to create rewrite rules then this is done on the plugin activation. The rules are added, the record flushed and reconstructed. What seems to be happening on your site is that the rules are being flushed at odd times when they should not be but NOT rebuilt so all of your pages are getting orphaned. That means the key to this might be trying to find out what is flushing them. And the most likely candidate would be another plugin…
But – try the update of both permalinks (Wp first then forum) as above to se if that makes it more stable.
Ok. So just to be clear. When I mean update all i am doing is going into the permalinks in the settings and hitting save. I am not changing anything. So you also want me to go to the SPF admin Intergration>page and permalink and hit update WP integration also?
No. I want you to go to the SPF admin Integration > page and permalink and click on the ‘Update Forum Permalink’ button AFTER updating the WP permalinks.
That did not work. But I found the Culprit. Its a plugin I used called Better WP Security. It has an option called Intrustion Detection. Which does the following:
404 detection looks at a user who is hitting a large number of non-existent pages, that is they are getting a large number of 404 errors. It assumes that a user who hits a lot of 404 errors in a short period of time is scanning for something (presumably a vulnerability) and locks them out accordingly (you can set the thresholds for this below). This also gives the added benefit of helping you find hidden problems causing 404 errors on unseen parts of your site as all errors will be logged in the “View Logs” page. You can set threshholds for this feature below.
I disabled that the whole plugin for a few days and did not get one error. I just find it strange how I didnt have that issue with BBPRESS. Maybe people werent interested in hacking BBPRESS like they are SPF
Thanks for your help Yellow
Encountered and heard of a lot of problems with that plugin actually.
I should imagine this has everything to do with the method SP uses to display itself and this security plugin not understanding it. BBPress creates entries in the WP posts table so each topic has a unique entry in that table. SP only has a single page entry in that table and the urls are derived using rewrite rules. This IS a WP mechanism but I suspect the security plugin doesn’t deal with as it should and just notices repeated requests to the same page but with different urls appended.
Well I figured it throw it in here just in case anybody uses it and is having the problem. Thanks for the Help
Its still happening. Im taking the forums down for 48 hours to see if I get any 404 erros. I just have to clear my head thats its not related to your plugin. I will keep you posted.
It may very well be related to SP but the cause is not going to be uniquely SP otherwise I do not think we would have any users at all!
Well it has been giving me that 404 issue ever since I installed it. It gives it to me at least 3 times a day. I removed a bunch of programs and it still doing it. Too bad because its an awesome plugin. So far I havent had any 404 issues since I deactivated it . Here are a list of active plugins that I have. If you think you see one that might of given you problems in the past I will deactivate it.
Akismet
BAW Login/Logout menu
Blog in Blog
BP Group Management
BuddyMobile
BuddyPress
BulletProof Security
Contact Form 7
Contact Form DB
Display Posts Shortcode
Facebook Page Publish 2
Google Analytics for WordPress
Instagram-Widget-for-WordPress
Maintenance Mode
Members Import
Participants Database
PSN Status Widget
Redirection
Rewrite Rules Inspector
Simple:Press V5 Importer Framework
Simple Login Log
Subscribe / Connect / Follow Widget
Theme-Check
TimThumb Vulnerability Scanner
Trackable Social Share Icons
Twitter Goodies
WangGuard
WP-Logs
WP-Polls
WP to Twitter
I only know of a small handful of these personally and certainly have no idea which ones may deal in rewrite rules or the creating/destroying of them. What dies ‘redirection’ do?