Support Forum

500 error after upgrade when trying to post

ST Steve20
Steve20
Member

I upgraded to the latest Simple Press last week and since then if a user tries to reply or post a new thread on the forum they get a 500 error and a message that the page isn’t working and my site is unable to handle the request.

There are no errors in the error log in the toolbox.

If I go to integrations and storage locations there seems to be some things missing:

Avatar Pool Folder

Forum Badges Folder

Simple Press Language Files

Simple Press Plugin Language Files

Simple Press Theme Language Files

Forum CSS/JS Cache

Any idea how to fix this?   Thanks,   Steve

25 Answers

New Answer

YS Yellow Swordfish
Yellow Swordfish
Member

So two things to discuss here.

The 500 issue wont show up in the php error log as it is a server status response You would hopefully find more information in the server logs which will be on the server and normally available to look at via your hosting/server control panel. Or your host might be able to shed more light on the root cause. They can be notoriously hard to track down…

As to the storage locations – most of these have bene in place since day 1 of version 5.0 so I guess my first question has to be – are you just seeing the storage locations admin panel tell you they can not see these? I.e. are they not there or are they not available to be used? The best way to check that is really to look at the  server folders to find out.

ST Steve20
Steve20
Member

Yes, I was just seeing these as missing in the admin panel so I thought that might be the cause of the problems with the 500 error.   I’ll have to get ftp access to check if they are there actually and I’ll take a look at the server logs.   Could those files being moved or deleted during the upgrade cause this 500 error problem?    Thanks

YS Yellow Swordfish
Yellow Swordfish
Member

It is doubtful that missing folders would be responsible for a 500 status as they would normally generate a 404 status. As I read recently…

Put simply, the 500 error is the Web servers way of saying “Something went wrong but I can’t tell you what, sorry.” This is what we call a “server-side” error. That means that there is something wrong with the server who is hosting the website.

As those folders have been in place for a long time – one reason they could not be seen AND could cause a 500 status is if the permissions to access them was incorrect. But you would surely know if permissions had been changed on your server recently.

And no – those folders were not touched during any recent upgrade of SP

ST Steve20
Steve20
Member

is there a way to do a fresh install of simple press without losing all previous thread and user data?

MP Mr Papa
Mr Papa
Member

users belong to wordpress… we do add bit more info…  but no… if you uninstall simple press, you will lose your groups, forums, topics and posts…

ST Steve20
Steve20
Member

So I checked the sp-resources file through ftp and these folders are missing

Avatar Pool Folder

Forum Badges Folder

Simple Press Language Files

Simple Press Plugin Language Files

Simple Press Theme Language Files

Forum CSS/JS Cache

Are these supposed to be in that folder like the Integrations-storage page says?   If so where do I find these folders?   I downloaded a fresh install file of Simplepress but couldn’t find any of these files in the install file………..

ST Steve20
Steve20
Member

Also,   I had my website guy check the server error logs and although he sees the 500 error caused by trying to post on the simple press forum there is no information on the error as to why this is happening………

MP Mr Papa
Mr Papa
Member

not sure what you mean by sp-resources file?  do you mean directory?

not all of those are needed, only if using… but you could just manually create them to get the storage locations page showing all green..  none of those will prevent, posting however…

does your server run mod_security or other firewall type sw that may be interfering?

ST Steve20
Steve20
Member

No,  I don’t have any mod_security or other firewall set up………..

MP Mr Papa
Mr Papa
Member

so stepping back…  what version did you upgrade from?  and assume you are on WP 4.5+?

and it was working just fine with the missing storage locations, right?  as we have said, not likely at all to be related to the 500 error…  and  certainly not as part of the upgrade since they are not touched…

and 500 errors are the hardest to find because they are related to server issue vice php code issue and as  you have seen from the error logs, no information is given…

When you get this error, what is the url is is on?  ie what is the url loaded that yields the message?

can you give us a link to your site so we can look for other issues?

is there anything else not working?

can you verify the permissions and ownership of the wp-content and simple-press folders (and files within)? 

ST Steve20
Steve20
Member

The website is www.neffmusic.com but the forum is for member’s of the site only so if you want to get in there i would have to create a membership for you.

The http error 500 happens when I try to post a reply to a thread or start a new thread.   Here is a sample URL after I try to post a reply that gets the 500 error:

http://www.neffmusic.com/blog/index.php?sp_ahah=post&sfnonce=c2d30fd95a

I upgraded from 5.6.4 to 5.6.6 when this issue started.  I updated to 5.6.7 yesterday hoping it would fix it but still the same problem.

As I am testing around the forum I just noticed that the “View New Posts” button isn’t working. Nothing happens when I click on it even though it says there is one new message.

When I click on “Watching” or “Subscribed” buttons i get a message that “Ajax check nonce failed” “Do you need to log in?”  and it redirects the page to the wordpress login page.  I am already logged in when this happens so I’m not sure why it is doing this………….

I tried disabling all plugins other than SimplePress but the issue is still there so I don’t think it is another plugin.

I have to wait to tonight to talk to my website guy to see about checking the permission on the simple press folders.    Let me know what you think.    Thanks,   Steve

YS Yellow Swordfish
Yellow Swordfish
Member

Have you put in place any Security plugins (for example) – or changed server setting recently? This is starting to sound like the AJAX calls that SP makes are being denied by your server. This might be a more productive area to check out…

Anther possibility would be if you have recently added the server mod_security module… that might well be barring some of the forum URLs… Possible?

ST Steve20
Steve20
Member

You can disregard this comment.

When I click on “Watching” or “Subscribed” buttons i get a message that “Ajax check nonce failed” “Do you need to log in?”  and it redirects the page to the wordpress login page.  I am already logged in when this happens so I’m not sure why it is doing this…………

I found an old post on this forum about “ajax check nonce failed”  and it said to try reloading the page and that fixed it.

The main problem is back to the not being able to post because of the 500 error.  I do have WP Security plugin but nothing has been changed on that plugin.

MP Mr Papa
Mr Papa
Member

yes, wp nonces have limited shelf life… if one sits on the page for a while, they will time out and no longer work…a security feature..

what security plugin please?

also, cant see the forum as you mentioned, but notice you are using wp rocket… are you using for caching or minimizing scripts?  if so, this could be your problem…