I have one user, which is a moderator, reporting this issue and I can repeat it when logged in as that user. It does not happen when logged in as an admin from my personal experience and no one else has reported the problem.
Whenever the user attempts to reply to a topic the “post saved” modal appears then as the page reloads to show the post with the new reply the following error is displayed:
Access denied – you do not have permission
Warning: Cannot modify header information – headers already sent by (output started at /problem-with-post-edit-buttonome/XXXXXX/public_html/wp-content/plugins/simple-press/sp-api/sp-api-primitives.php:59) in /problem-with-post-edit-buttonome/XXXXXX/public_html/wp-includes/pluggable.php on line 1173
Here are the relevant error log entries:
line: 758
function: fread
Warning | fread(): Length parameter must be greater than 0
November 10, 2014 3:52 am | spaErrWarning | 1 | phpfile: /simple-press/sp-api/sp-api-plugins.php
line: 588
function: fread
Warning | fread(): Length parameter must be greater than 0
November 10, 2014 4:13 am | spaErrNotice | 2 | phpfile: /simple-press/sp-startup/admin/spa-admin-framework.php
line: 401
function: spa_check_warnings
Notice | Undefined index: active
November 10, 2014 3:54 am | spaErrNotice | 3 | phpfile: rtsock/public_html/wp-content/sp-resources/forum-plugins/admin-bar/library/sp-admin-bar-components.php
line: 15
function: sp_admin_bar_do_new_post_list
Notice | Undefined property: spUser::$sfadminbar
November 5, 2014 9:34 pm | spaErrNotice | 1 | phpfile: /simple-press/forum/profile/forms/sp-form-profile.php
line: 109
function: include_once
Notice | Undefined property: spUser::$location

