Hello team,
I noticed today that its no longer possible for users of my forum to upload attachments.
Here is a short video which explains the issue.
Any ideas for a fix?
Thank you for the support.
Hello team,
I noticed today that its no longer possible for users of my forum to upload attachments.
Here is a short video which explains the issue.
Any ideas for a fix?
Thank you for the support.
The big question really is what else on your website has changed as this clearly looks to be a script conflict of some kind – maybe with your WP theme or another plugin. So changes/updates to any of these components or adding something new could all be the root cause of the problem.
If you can not answer that one and can not deactivate anything to test it out then try loading the page and exposing the attachment section with the web console open to look for errors. These will traditionally show up in red. Let’s see what it says!
For a quick and simple guide to using the console to look for script errors please see:
https://simple-press.com/documentation/codex/faq/how-to/how-to-use-your-web-browser-console/
Thank you for the help. I have not found anything else on the website which has changed (at least not yet).
I think this happens whenever I update the SP forum plugin. Usually I ask my tech guy to fix it, and in the past he has fixed the blog side bar post thanks code by adding the following to the functions.php file:
function wpc_shortcode_postthanks(){ if (function_exists(‘sp_thanks_user_stats’)) { ?><div style=”width:100%; margin:0px 0 10px; padding:0%; float: left; text-align: center;” > <?php sp_thanks_user_stats(‘tagclass=spCenter spThanksUserStats’, get_current_user_id(), ‘<span style=”padding-top: 10px;”>Thanked %THANKED% times</span>’); ?></div> <?php } else{ //echo ‘no action’; } } add_shortcode(‘postthanks-short-code’,’wpc_shortcode_postthanks‘); ?>
However that must get erased when we update the plugins, because I remember having him re-add it several times over the past year or so.
I tried Web Console and here’s what I found. When I load my blog and search for errors I see:
I then when I click on “Show All Messages” I see:
Does this help?
Thanks again for your support!
I’m sorry about the above post! That was in reference to another issue which I also started a thread about. My apologies for the posting confusion.
So I checked out the forum page using Web Console and here is what I found:
Let’s reply to both of the above posts anyway.
Yes – if your code guy is putting that code in the theme functions file then it will get overwritten on every update. The way to avoid this is to use the appropriate child theme. These are available free from our store. Install the child theme – switch to using the child theme and put the code in the child themes spFunctions file. This will NOT get overwritten in any updates.
As to the console messages regarding uploading then I am not sure what they mean. Are you sure that all SP plugins are also fully up to date? And I will talk to my colleague @mr-papa to see if he has any ideas about that error message.
Thank you.
Yes all SP plugins are up to date, but I’m still not able to upload attachments.
Any insight is welcome.
@mr-papa – do the errors shown in the console image above mean anything to you?
The problem is that BOTH buttons (add and upload) are disabled. First time I have seen this…
not really… is this an old version of IE?
would be nice to have a link to the site where its occurring…
Its using the combined js cache, so perhaps go to forum – toolbox – houskeeping and try clearing the combined js cache… if that doesnt help, might even go to forum – options – general settings and turn off the combined js cache…
perhaps you have another plugin that is trying to compress or minimize js scripts.. they often fail on the forum js because its already minimized…
Thanks for the reply.
I’m using the latest version of Google Chrome.
Here is a link to the forum. I can create a username/password for you if you’d like.
I tried clearing the caches (I clicked the two buttons in this image).
I also tried unchecking the combined JS cache…
Still the issue persists and I am not able to use the upload attachment buttons.
Regarding the other plugins that compressive JS scripts…I honestly have no clue. Maybe I will end up hiring someone to fix this problem for me?
Thank you!
Could you please create an account so that we can log in and see the forum behaviour. Please send a PM to both myself (Yellow Swordfish) and Mr Papa.
It helps if you can include links to not just your forum but also to this topic so we can get to it quickly to re-read what has been said. A brief reminder of the problem is also very helpful.
The issue seems to have something to do with Google Chrome. The buttons are working with Firefox and Safari.
I will send you both credentials via PM. Thanks for the assistance.
Curious. And I assume your Chrome is up to date?
It is the browser I mainly use so will be interesting to see.
I have left a post in the ‘General’ forum where the attachments worked just fine. Now this is using Chrome on a Mac.
I can not test it under Windows so I will ask @mr-papa if he can do so using his machine and chrime browser. Maybe add something to the same topic is possible…
Thanks! I am also using a Mac.
When I am logged-in as an “admin” it is not working, but when I login as a regular user I can upload successfully.
So it looks like the admin is not able to upload avatars when using Chrome on Mac. Overall I’m happy the issue seems to be only affecting admins.
Any idea how I can get it working for admins?
PS – I am going to change your account to “admin level” so you can see what I mean. I am also going to delete your most recent test post so users aren’t wondering what that is all about 