Support Forum

Database issues and large error log files crashing site.

WA wagley
wagley
Member

Hello, My site has been experiencing lots of large error logs files (over 150mb) and the site is crashing often. I’m not sure if this is a Simple:Press or WordPress issue.

Visitors get an “Unable to connect with database” error when the site goes down. We are running on a dedicated server with WP version 3.5.1 and Simple:Press 5.2.2

Snipped below is the recent error logs from  SP/Administration/Toolbox/Error Logs. I am happy to provide the complete error logs from the server.

If you have any help and insights, I would be grateful.

Thanks, Jerry

Date Type Description
February 20, 2013
11:29 pm
php file: /simple-press/sp-startup/forum/sp-forum-support-functions.php
line: 159
function: sp_populate_support_vars
Notice | Trying to get property of non-object
February 20, 2013
11:29 pm
php file: /simple-press/sp-startup/forum/sp-forum-support-functions.php
line: 158
function: sp_populate_support_vars
Notice | Trying to get property of non-object
February 20, 2013
11:29 pm
php file: /simple-press/sp-startup/forum/sp-forum-support-functions.php
line: 157
function: sp_populate_support_vars
Notice | Trying to get property of non-object
February 20, 2013
8:04 pm
php file: wtos9/public_html/wp-content/sp-resources/forum-plugins/watches/template-tags/sp-watches-watch-button-tag.php
line: 50
function: sp_WatchesWatchButtonTag
Notice | Trying to get property of non-object
February 20, 2013
8:04 pm
php file: wtos9/public_html/wp-content/sp-resources/forum-plugins/subscriptions/template-tags/sp-subscriptions-subscribe-button-tag.php
line: 52
function: sp_SubscriptionsSubscribeButtonTag
Notice | Trying to get property of non-object

9 Answers

New Answer

YS Yellow Swordfish
Yellow Swordfish
Member

(I trimmed your table above as the rest were just repeats of the same notices).

Several things to say about this!

First one, I guess, is to just point out that these are not errors. These are, as they all say, Notices. They are not a problem in themselves but they are a nuisance and whenever we get one reported we do clean it up. This does not always stop it being reported for ll users as so much is conditional and depends on users data and third party influences. But I will look these 5 up to see if I can spot anything.

Next you might want to question whether you want your error log to be filled up with notices. Errors always – and probably Warnings also. But Notices? Just turning those off in your php ini is going to make a big difference. When I have mine on I get many, many entries as well – from SP, WordPress and other plugins. As you have a dedicated server I would suggest you consider turning them off. And, of course, regularly deleting the error log file!

I think you may have the next item back to front – that when the site crashes users get a ‘cannot connect to database’ message. I suspect that it is because the connection is lost that the site crashes. This is the message that WordPress displays when it loses the connection to your database. On these occasions, I would expect to see error log entries (in the server error log fikle) along the lines of ‘The mySQL engine has gone away’.

I am unfamiliar with all of the reasons the connection can get lost. Using up the php memory can trigger it of course but more usually, I believe if it is a busy site there may not be enough connections available and it will be more a matter of tweaking your mySQL settings and perhaps giving the database some extra resources. I would suggest keeping an eye on the error log and keep deleting it when it is fairly small and see if this also solves the connection issues. If it does not then i think this is something you need to take to your host.

I will see, as promised, if those 5 notices have been dealt with and if they have not will get them into the forthcoming 5.2.3 however.

YS Yellow Swordfish
Yellow Swordfish
Member

Ok – looking at the code I think I can see why your system is throwing these notices.

At some point in the past I believe you have deleted a sub-forum but the clean-up operation – i.e., removing all traces – may have failed or not been run. Is this possible or likely? Or have you ever deleted a forum directly in the database table for any reason?

WA wagley
wagley
Member

I have not deleted a forum directly from the database but there have been topics and sub-forums deleted within Simple:Press. What is a way to clean that up you refer to?

And yes, I regularly delete the error logs.

YS Yellow Swordfish
Yellow Swordfish
Member

Do you know you way around a database so that you could look at the data for me? Or – even make an export of a table so that I could look at it for diagnosis?

WA wagley
wagley
Member

Sure, either one.

I am familiar enough with snooping around inside the database but will ask for help before I venture into the hinterlands.

If you want the whole thing that is fine– it is 250mb.  If you want just the “sf” tables, I can do that too. Let me know how to deliver it.

Also, sorry the delayed responses. I’ve been busy on other projects in far away places.

MP Mr Papa
Mr Papa
Member

sorry, not sure where andy was going here… he will be back from a short vacation tomorrow and will try to help…

WA wagley
wagley
Member

Also.. I found these odd lines (have not seen this before) in the error log on the sever. I have seen the “Try to get property of non-object” notice (duh). BTW, the site crashed and the forums would not load on this day around this timestamp.

[18-Feb-2013 01:34:07] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘WHERE forum_id=11’ at line 1 for query UPDATE wp_sfforums set group_id= WHERE forum_id=11 made by require(‘wp-blog-header.php’), wp, WP->main, WP->parse_request, do_action_ref_array, call_user_func_array, sp_ahah_handler, include(‘/plugins/simple-press/admin/panel-forums/ahah/spa-ahah-forums-loader.php’), spa_save_forums_delete_forum, spa_clean_forum_children, spdb_query
[18-Feb-2013 01:34:07] PHP Notice:  Trying to get property of non-object
[18-Feb-2013 01:34:07] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘WHERE forum_id=19’ at line 1 for query UPDATE wp_sfforums set group_id= WHERE forum_id=19 made by require(‘wp-blog-header.php’), wp, WP->main, WP->parse_request, do_action_ref_array, call_user_func_array, sp_ahah_handler, include(‘/plugins/simple-press/admin/panel-forums/ahah/spa-ahah-forums-loader.php’), spa_save_forums_delete_forum, spa_clean_forum_children, spdb_query
[18-Feb-2013 01:34:21] PHP Notice:  Trying to get property of non-object

YS Yellow Swordfish
Yellow Swordfish
Member

That still looks like you have some stranded children (sub-forum) flags.
I think what I need is just the ‘sfforums’ table. If you can export that, zip it up and email it to support at simple-press dot com I will take a look at it and then we can see what is wrong.