Support Forum

Error 999 – Unknown server error (check image size – may be exhausting memory)

AC Aureo Castillo
Aureo Castillo
Member

I tried attaching images or any file types (e.g. pdf, txt,etc) but I am receiving initially a status is null message and then after which the error 999 message.

Settings for sizes are set to “0” or unlimited.

error_msg.png

Please advise if I miss anything in our setup. TIA.

20 Answers

New Answer

YS Yellow Swordfish
Yellow Swordfish
Member

I will probably need to involve Steve (Mr Papa) on this one and he may not be able to get to the forums today. But… the message you are seeing there is not related to the SP settings. As it says – you have received some sort of server error.

You do not say how large the file was you were attempting to upload but it could be that it is larger than your allowed size as set by your server environment. Uploads will normally (by default) be set at 2MB max and there is also a limit on how large data can be that is ‘posted’ (in http terms) to a server. It could also be that your ‘tmp’ folder – a location defined by php where all uploads are sent to before being processed and then moved – is full.

You may need to look at your php error logs to find out the underlying problem or perhaps ask your host if you should have been able to upload the files – remember this is using the POST http protocols.

So the size of the file is the first thing to establish.

AC Aureo Castillo
Aureo Castillo
Member

The file that I am trying to upload is not significant, not more than 350kb.

YS Yellow Swordfish
Yellow Swordfish
Member

Have you managed to take look at the php error log file?

AC Aureo Castillo
Aureo Castillo
Member

Yellow Swordfish said
Have you managed to take look at the php error log file?

I have checked the error log file, there are no reference about uploading image error on it. Let me know if you want me to post or send you a copy. 

On the other hand, I have already checked with my host and they mentioned that the image upload limit is set to 750M.

MP Mr Papa
Mr Papa
Member

so we need to know a couple of settings on server…

memory_limit
file_uploads
upload_max_filesize (is this what you reported in previous post?)
post_max_size

and is this occurring for ANY upload?  typically this means server config error… the 999 code means it just dies and did not report anything back to us…

have you defined a temp upload location?

upload_tmp_dir

all those are defined in the php.ini file… is this nix or IIS?  the latter does not define and temp upload by default…

AC Aureo Castillo
Aureo Castillo
Member

Hi Mr. Papa,

The following are the values:

memory_limit: 512M
file_uploads: ON
upload_max_filesize: 750M
post_max_size: 700M

What I think is off is the upload_tmp_dir which states no value. I am coordinating with my host about this currently.

AC Aureo Castillo
Aureo Castillo
Member

Just to clarify as well, is there any specific value that I have to request to our hosts regarding upload_tmp_dir or anything that I have to setup within the simple press admin?

TIA

MP Mr Papa
Mr Papa
Member

for most *nix systems, it will be /tmp… can be anything as the web user (ie apache) can write there…

AC Aureo Castillo
Aureo Castillo
Member

our hosts has changed the upload_tmp_dir  and the value is /tmp.

i just checked but still get the same error. do I need to check on something else? Kindly advise.

 

TIA

AC Aureo Castillo
Aureo Castillo
Member

Aureo Castillo said
our hosts has changed the upload_tmp_dir  and the value is /tmp.

i just checked but still get the same error. do I need to check on something else? Kindly advise.

 

TIA

just to follow up on my inquiry. kindly advise the next steps. Thank you very much.

MP Mr Papa
Mr Papa
Member

you never answered (or I missed it) as to whether this is a unix type system of IIS…

have you tried with multiple browsers?

a bit puzzled…  its a server config of some sort – its not our code running when the error occurs which is why we dont get any more info and just throw the 999 error…  we have not run across anyone yet where that 999 wasnt resolved in the server config…  but not sure what else to check…

AC Aureo Castillo
Aureo Castillo
Member

Mr Papa said
you never answered (or I missed it) as to whether this is a unix type system of IIS…

have you tried with multiple browsers?

a bit puzzled…  its a server config of some sort – its not our code running when the error occurs which is why we dont get any more info and just throw the 999 error…  we have not run across anyone yet where that 999 wasnt resolved in the server config…  but not sure what else to check…

My apology if I missed it. Anyway, the server is running on a Linux version running on PHP v5.2.17. I tried it on a firefox, chrome and safari browser. I will try later on an IE browser.

Our hosts is asking us what needs to set up on their server side to make this work. Any suggestions?

TIA

MP Mr Papa
Mr Papa
Member

can you verify that your server has json installed on it? its a part of a typical installation but worth checking… the js from the 3rd party file uploader uses json to return a response, so maybe that is where the error is coming from…

AC Aureo Castillo
Aureo Castillo
Member

yes. it was verified that JSON is installed in the server.