Support Forum

Error 999 – Unknown server error (check image size – may be exhausting memory)

20 Answers

New Answer

AC Aureo Castillo
Aureo Castillo
Member

Hi, To try if the server is really the problem, I created a new sub-domain and installed a fresh install of WP and SP. This is running on the same hosts or server machine and apparently the problem is not existent which means that i can attach any files including any type of images in a post. 

Having said that, any suggestion on how to best resolve this?

I am thinking of re-installing SP to test if that will completely resolve the issue but I am not sure or could not find any information on how to back-up the data. Do you have any suggestions or things to consider if I take this route?

TIA

YS Yellow Swordfish
Yellow Swordfish
Member

Curious.

on the re-install front – theory says that it should make no difference and I can think of no good reason to recommend such a course of action. If you backup and then restore the data then you have not changed anything there anyway. If you want to re-install the code files then you could simple remove them from the WP plugins folder and upload a fresh copy. Whatever you do do NOT use the uninstall tool as that will wipe the data out.

An alternative strategy would be to take a look at what other WP plugins you have installed. While being perhaps unlikely that any could have this effect it is not outside the realm of possibility that one of them may be conflicting in some unknown way. If you have the opportunity to deactivate other plugins – trying the upload between each one – at least it would count them out.

AC Aureo Castillo
Aureo Castillo
Member

I just verified finally what’s causing this error. After doing both suggestions (disabling all WP plugins and uploading a fresh copy) what obviously was left was that the site is running under SSL (https). After disabling it, i can now upload or attach images or any file types.

Having said that, is there any way or suggestions that we can work around with it? It is quite critical for us to run our site in SSL. Hope we can find some ways on it. Please advise. Thanks.

MP Mr Papa
Mr Papa
Member

SP works fine with SSL…  has for a long time…  now, as luck would have it, I had to trash my SSL set up a couple weeks back and have not re-set it up, so cannot test directly… but we have a group of users that have been using SP or SSL for years…  and they have not reported any issues… and yes, they are on 5.0… 

but, first, lets check a few things…

please verify that you have the proper SSL flags set in your wp config file…

and go to forum – integration – page and permalink and make sure the listed permalink includes https in it…  if not, you may need to update the forum permalink…

AC Aureo Castillo
Aureo Castillo
Member

Just to update. After enabling SSL again. We can already upload images or attach files in SP. I could not really say what solved this but i just happen to disable SSL and when it worked I re-enabled SSL and after testing it can still upload images. It means that it is now working even after re-enabling the SSL. This is still without updating the permalink as suggested.

Anyway, I am still monitoring it but it seems working fine until now.

Thank you to Mr. Papa and Yellow Swordfish for the assistance and patience.

Cheers,

Aureo

YS Yellow Swordfish
Yellow Swordfish
Member

Wow… gremlins in the ether :)
I hope it continues OK as well. Thanks for the update.