Support Forum

Forum is blank page after update of WP and SP

MI Massimo Interlandi
Massimo Interlandi
Member

After upgrading today to WP 3.9.1 and latest SP I cant reach the forum anymore. I get a blank page without error messages.

Thanks for your help

13 Answers

New Answer

YS Yellow Swordfish
Yellow Swordfish
Member

You are probably getting some kind of php fatal error that is stopping processing. If this is the case it will place an entry in your php error log. Can you check that and see what it says? Just looking for the most recent one marked ‘fatal Error’.

MI Massimo Interlandi
Massimo Interlandi
Member

Hi Yellow Swordfish, I’m not that good at this unfurtunatly, where abouts  shoult I look for it.. sorry for my ignorance

YS Yellow Swordfish
Yellow Swordfish
Member

Understood. Let’s check first if it is necessary to look. Can you give ma a link to your forum page?

You could also check the forum admin > toolbox > error log for an error (JUST an error) but I doubt it will be n there as it probably happened before SP started to load.

MI Massimo Interlandi
Massimo Interlandi
Member

just PM you with credentials for backoffice.

Thanks a lot.

YS Yellow Swordfish
Yellow Swordfish
Member

I appreciate why you sent these PMs but I am afraid they do not help any.

You do need to look at your php error log.

OK – I assume that with your hosting you get a control panel. If this is cPanel then there is an option on that to look at the php error log and it will load it into a window. If any other control panel then hopefully that will do the same.

Assuming you can look at the log you are looking for a recent one that states it is a ‘fatal error’.

MI Massimo Interlandi
Massimo Interlandi
Member

Thanks for that.

Ok this is what the file says:

“[Tue Jun 03 07:19:42 2014] [error] [client 109.55.55.43] File does not exist: /problem-with-post-edit-buttonome/cuffie5/public_html/forum, referer: http://cuffiehifi.info/wp-admin/admin.php?page=simple-press/admin/panel-forums/spa-forums.php

[Tue Jun 03 07:19:29 2014] [error] [client 66.249.76.213] File does not exist: /problem-with-post-edit-buttonome/cuffie5/public_html/2014

[Tue Jun 03 07:19:20 2014] [error] [client 208.115.113.92] File does not exist: /problem-with-post-edit-buttonome/cuffie5/public_html/category

[Tue Jun 03 07:17:48 2014] [error] [client 216.54.31.82] File does not exist: /problem-with-post-edit-buttonome/cuffie5/public_html/forum

[Tue Jun 03 07:17:44 2014] [error] [client 216.54.31.82] File does not exist: /problem-with-post-edit-buttonome/cuffie5/public_html/forum”

YS Yellow Swordfish
Yellow Swordfish
Member

Well that makes little sense…. weird.

How did you perform the various upgrades please?

Hold on. This: /problem-with-post-edit-buttonome/cuffie5/public_html/forum – is not a valid location.

MI Massimo Interlandi
Massimo Interlandi
Member

Solved!

That was a lot of luck on my side since without even knowing what I was doing I went to the cPanel and refreshed (fixed) WP database.

All great again now.

Following my upgrade steps:

1.WP upgrade

2. SP upgrade

3. All SP plugins upgrade.

But something went wrong since the site was perfectly working just before then.

MP Mr Papa
Mr Papa
Member

good news… sometimes the order of plugin activation can change things (priority on hooks, for example)… so when you updated, that may have changed… but glad its working…

TE Teresa
Teresa
Member

This happened to me. In my case (after a bit of troubleshooting with my web host, trying to find a php errors) — I happened to notice that there was no “forum” listed on my dashboard. Odd. So I went to the plugin page and, uh, I saw the “activate” where all the other plugins said “deactivate.” So I clicked on “activate,” and was prompted to upgrade to 5.5 (which I had done, but I did it again) and — all is well.

 

Just mentioning it here in case anyone finds this thread, as I did, in troubleshooting their own update that results in the forum no longer appearing. 

 

Anyway, all is well now. 

MP Mr Papa
Mr Papa
Member

what version did you upgrade from?  and assume it was from the wp updater?

wp does deactivate a plugin when updating it, then reactivates it… anything in the error log that might indicate why it didnt get reactivated?

TE Teresa
Teresa
Member

Hi Mr. Papa,

 

I am not subscribed to the forum and didn’t see your post until now. 

 

I upgraded from (I believe) the previous version. 5.4.1?

 

I do not know where the error log is to check it. 

 

Regards,

Teresa

MP Mr Papa
Mr Papa
Member

the php error log is host dependent…  they tend to put it in different places… or you can access it via your hosting control panel usually…