Support Forum

Forum Support

BW Brandon Williams
Brandon Williams
Member

Hello,

I posted over a month ago about an issue with upgrading my Simple Press forum, and you guys gave me some tips to figure it out. Well, after going through a developer, we are still having issues. Is there a way someone from Simple Press can fix this? What would the rate be? Our site is missing out on this feature and we definitely need it fixed as soon as possible. Thanks.

14 Answers

New Answer

YS Yellow Swordfish
Yellow Swordfish
Member

Have you tried and failed to upgrade SP today? As we do seem to have had a problem, which I believe is now fixed although I await a user trying and confirming this… Or is this unconnected?

BD Bruce Dienes
Bruce Dienes
Member

Just tried to update and still getting error

An error occurred while updating Simple:Press: The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

MP Mr Papa
Mr Papa
Member

thats just confusing..  no issues with other upgrades occurring – just tested myself… and even worse, the upgrade is actually done by core wp code – not ours…

interestingly, lots of similar wordpress forum topics with same issue for wp core and other plugins…  one topic that caught my eye:  https://wordpress.org/support/topic/incompatible-archive-pclzip_err_bad_format-10?replies=36  the one from audiodel and mbstring…

does you server have mbstring support in php enabled?  both wordpress and simple press use it, but it wont always get invoked… and we have seen couple odd issues for folks in other spots that did not have mbstring support turned on…

BD Bruce Dienes
Bruce Dienes
Member

I have tried various edits to the php.ini file as suggested, checking disk space, etc. and no change.

I can update any other plugin on the site (see pic), but when I try to update SP or any SP plugin, I get the error, so I think this may be a SP issue.

simple-press-error-1.jpg

Note: Error Log:

  1. [Fri Jul 08 11:52:54 2016] [error] [client 24.53.82.137] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace., referer: http://quaker.ca/wp-admin/network/update-core.php
  2. [Fri Jul 08 11:53:05 2016] [error] [client 24.53.82.137] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace., referer: http://quaker.ca/wp-admin/network/update-core.php?action=do-plugin-upgrade
  3. [Fri Jul 08 11:53:17 2016] [error] [client 24.53.82.137] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace., referer: http://quaker.ca/wp-admin/network/update.php?action=update-selected&plugins=simple-press%2Fsp-control.php&_wpnonce=xxxxxxxxxxxxx
  4. [Fri Jul 08 12:38:24 2016] [error] [client 180.180.71.35] WordPress database error Table ‘cymmulti2.wpmu_6_sflog’ doesn’t exist for query SELECT version FROM wpmu_6_sflog LIMIT 1 made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), include_once(‘/plugins/simple-press/sp-control.php’), include_once(‘/plugins/simple-press/sp-startup/sp-load-core.php’), include_once(‘/plugins/simple-press/sp-startup/site/sp-site-constants.php’), spdb_select, referer: http://quaker.ca/
YS Yellow Swordfish
Yellow Swordfish
Member

Curious error entries – none of which mean much to me personally – so we will need to research them to see if we can determine if any of them are relevant. Will need to come back to you…

YS Yellow Swordfish
Yellow Swordfish
Member

Ok – bearing in mind that I (again personally) am a long way from being a server expert, a quick search does suggest that those ‘Request exceeded the limit of 10… etc‘ error entries are likely caused by an issue if your server .htaccess file. There are a couple of links here that both relate to this issuer and WordPress installs that might be worth trying…

http://stackoverflow.com/questions/22756796/apache-2-4-request-exceeded-the-limit-of-10-internal-redirects-due-to-probable

https://buddypress.org/support/topic/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error/

But still looking and I will bring a colleague unto the discussion as well later on.

MP Mr Papa
Mr Papa
Member

and just as curious as the code that unzips/extracts the zip file is WP itself… there is not simple press code that does it…  its just an extension of the wp class where we change where the file comes from…  notice all the errors are from wp core files…

as mentioned in previous post, lots and lots of this bad zip error in the wp support forum for core and plugins…  the internal redirects is an interesting add on to that…

so would be most interesting to see what you .htaccess is and how it might differ (or not) from standard wp…  is this standard wp (vice multisite)?

BD Bruce Dienes
Bruce Dienes
Member

I tired some of the changes to the .htaccess but it did not fix the issue.

These seems to happen only with the SP plugin, and not with any others on the same sites (I’ve tried it on two different sites)

MP Mr Papa
Mr Papa
Member

I can add that there has been a second report of this…  and we continue researching.. but hard when its not generally happening with vast majority working fine…  and seems to be related to a server config we cannot replicate…

so lets make sure we have the right data…  wp 4.5.3…  sp 5.6.7…  what version of php?  and this is standard wordpress (not multisite)?

also, do you know which method wp uses on your server for updates (ie direct, ssh, ftp, etc)… more info here:  https://codex.wordpress.org/Editing_wp-config.php#WordPress_Upgrade_Constants

BD Bruce Dienes
Bruce Dienes
Member

I tried the FTP settings changes from the link you gave, but got the same error with ftpext and ftpsockets. So set back to default (which would be direct).

Note that the SP plugins also will not update. Are you using a nonstandard option when you create the zip files? All other plugins will update with no problem.

This is a directory-based multisite. Here’s the environment report:

Simple:Press   Version: 5.6.5
Build: 14127
Release: Release
WordPress   Version: 4.5.3
Language: en-US
Character Set: UTF-8
Theme: Sterling Child Theme
PHP   Version: 5.3.28-pl0-gentoo
Memory: 384M
Max Upload: 20M
Timeout: 300
MySQL   Version: 5.1.66
Prefix: wpmu_7_
Server   Version: Apache
WP Plugins   404 to 301 (2.2.7)
Blog Posts Shortcode with Featured Image (1.0)
Broken Link Checker (1.11.2)
Contact Form 7 (4.4.2)
Customize Login Image (2.0)
Disable Comments (1.5)
Email Encoder Bundle – Protect Email Address (1.4.5)
Multisite User Management (1.1)
Recent Posts function and Shortcode (3.0)
Simple:Press (5.6.5)
Slideshow (2.3.1)
Snapshot (2.5.0.1)
Social Media Widget (4.0.5)
Toolset Module Manager (1.6.5)
Toolset Types (2.1)
Toolset Views (2.1)
W3 Total Cache (0.9.4.1)
Wordfence Security (6.1.10)
WP-Members (3.1.2)
WP Add Mime Types (2.0.4)
WPMU DEV Dashboard (4.1.0)
SP Plugins   Admin Bar (1.5.1)
Announce (1.0.7)
Editor TinyMCE Rich Text (3.2.6)
Featured Topics and Posts (1.0.11)
File Uploader with Plupload (4.3.3)
Font Resizer (1.2.1)
Maintenance Mode (1.0.4)
Membership Subscribe (1.0.5)
Polls (1.5.16)
Post Preview (1.2.11)
Search (1.1.6)
Subscriptions (1.4.17)
Tags (1.3.31)
Topic Description (1.2.8)
Topic Redirect (1.0.4)
Uploads Viewer (1.1.14)
Watches (1.5.14)
MP Mr Papa
Mr Papa
Member

nope, nothing non standard in zip generation… just steady old winzip…

ah thanks for info on the file settings…wasnt really asking you to try another (but thanks!) – was just gathering data…

so this is multisite, eh…  will do some testing on upgrades on that setup myself just to be sure…  we have tons more users on stanard wp than ms… but the code base is the same…  can you tell me is this a network upgrade or single network site?  if network site, is the main site or one of the lower network sites?  also, does your multisite use the old file storage structure (blogs.dir) or the new one (in wp-uploads, by default)..  and lastly, are all the sites in the ms using same storage?

so you are a couple versions behind… shouldnt matter, but perhaps another small test you could do…  go here:  https://simple-press.com/documentation/codex/installation/upgrading/previous-simplepress-versions/ and download the 5.6.6 version and manually upload it via ftp…  then see if you can update to 5.6.7?  wp has been making lots of changes in multisite the last handful of releases and we have stayed up to date (we think)… dont think this step will fix anything, but worth trying…

thanks for staying with us and trying to debug this issue…

MP Mr Papa
Mr Papa
Member

Can you please try again?  think we may have resolved the issue…

BD Bruce Dienes
Bruce Dienes
Member

Whatever you did fixed it! I can upgrade now.

Thanks!

YS Yellow Swordfish
Yellow Swordfish
Member

Great news. Thanks for the confirmation. We were lucky to find it. It was an issue in a separate, non-forum, component that was causing error text to be sent and it was the error text that got sent back to your PC – hence not a zip file at all! Fixing that fixes the problem. Thanks for sticking with it and apologies.