Support Forum

No admin menu after installation, access denied

YL Yao Li
Yao Li
Member

I followed the Installation guidance, clicked the “Install” button in the plugins page then I met the error message “

YOU WILL NEED TO PERFORM THE FOLLOWING TASKS TO ALLOW SIMPLE:PRESS TO WORK CORRECTLY

[Storage location part 1 ownership failed] – We were unable to create your folders with the correct server ownership and these will need to be manually changed: /var/www/html/wp-content/sp-resources

“

I clicked the button to the admin page, but it says “Access denied – you do not have permission”.

I can’t see the admin menu as shown in the codex page.

Here are the settings I’ve tried/checked:

  1. The current user has the capabilities:
    SPF Manage Admins
    SPF Manage Components
    SPF Manage Forums
    SPF Manage Integration
    SPF Manage Options
    SPF Manage Permissions
    SPF Manage Plugins
    SPF Manage Profiles
    SPF Manage Themes
    SPF Manage Toolbox
    SPF Manage User Groups
    SPF Manage Users
  2. The usermeta table in the database is assigned the same capabilities as well
  3. Only one page can be opened: wp-admin/admin.php?page=simple-press%2Fadmin%2Fpanel-admins%2Fspa-admins.php, which contains the Admin/Moderator Options
  4. I create a new role with all SPF items checked, and assign the role to my user
  5. I granted 777 to sp-resources directory

I’m using centos7, apache 2.4.6, php 5.4.16, mariadb 5.5.47.

Can anyone help me on the access issue? Thank you in advance.

Yao

21 Answers

New Answer

YS Yellow Swordfish
Yellow Swordfish
Member

It’s very rare but it does sometimes happen that we are unable to perform the unzip and transfer of those folders. I am not sure if we have ever found out why but it is going to be down to a server setting of some sort.

The message (which is not an error by the way) does suggest that the problem was assigning ownership so that is more than the normal permissions and could be the UID and GUID  attached to the parent, wp-content, folder.

The zip files (there are 2) can be found in the /sp-startup/install/ folder of the SP plugin so it might be worth unzipping them and then moving them to the correct location – which is under the /sp-resources folder by default.

We do remove the zip files at the end of an install so if they are not there you may need to download a second copy of the plugin and get them from there.

However, I would also check the UID and GUID setting on wp-content and make sure that your users will be able to write to them. Plus – if you ever add any SP plugins some of those will try and create a new storage folder which could easily fail if these permissions are wrong. I would also recommend not using 777 on sp-resources. Not only is that vulnerable as it leaves it wide open – but some server setups will not allow it to be written to as a security precaution. It really should be 775 for folders and 644 for files.

I have never tried or looked into mariadb so I do not know if query and syntax compatibility is 100%. I know it should be but that might depend on which version of mySQL it was forked from. We would obviously be unable to offer 100% support any specific issues you may encounter due to its use but would always try where possible. Let’s hope it is OK although I was unaware that WordPress itself supported it.

So – onto the permission to view the admin pages. That is somewhat odd and puzzling. You appear to have the correct role permissions set. To test these we use the standard WP core function current_user_can() so why that should return a false for a Simple:Press Admin user is rather strange and not something we have encountered before to the best of my memory. I am going to have to confer here to see if we have any ideas why this should be the case I am afraid.

For information – do you have any of the WP security plugins active?

YL Yao Li
Yao Li
Member

Yellow Swordfish said
It’s very rare but it does sometimes happen that we are unable to perform the unzip and transfer of those folders. I am not sure if we have ever found out why but it is going to be down to a server setting of some sort.

The message (which is not an error by the way) does suggest that the problem was assigning ownership so that is more than the normal permissions and could be the UID and GUID  attached to the parent, wp-content, folder.

The zip files (there are 2) can be found in the /sp-startup/install/ folder of the SP plugin so it might be worth unzipping them and then moving them to the correct location – which is under the /sp-resources folder by default.

We do remove the zip files at the end of an install so if they are not there you may need to download a second copy of the plugin and get them from there.

However, I would also check the UID and GUID setting on wp-content and make sure that your users will be able to write to them. Plus – if you ever add any SP plugins some of those will try and create a new storage folder which could easily fail if these permissions are wrong. I would also recommend not using 777 on sp-resources. Not only is that vulnerable as it leaves it wide open – but some server setups will not allow it to be written to as a security precaution. It really should be 775 for folders and 644 for files.

I have never tried or looked into mariadb so I do not know if query and syntax compatibility is 100%. I know it should be but that might depend on which version of mySQL it was forked from. We would obviously be unable to offer 100% support any specific issues you may encounter due to its use but would always try where possible. Let’s hope it is OK although I was unaware that WordPress itself supported it.

So – onto the permission to view the admin pages. That is somewhat odd and puzzling. You appear to have the correct role permissions set. To test these we use the standard WP core function current_user_can() so why that should return a false for a Simple:Press Admin user is rather strange and not something we have encountered before to the best of my memory. I am going to have to confer here to see if we have any ideas why this should be the case I am afraid.

For information – do you have any of the WP security plugins active?  

Thank you for the quick response. No I’m not using the WP security plugins.

I found the two zip files, and unzip them to the sp-resources directory. But it does not work…

For the UID and GUID check, I do not know how to do it…

Let me know if you need any information/data/snapshots.

Yao

YS Yellow Swordfish
Yellow Swordfish
Member

Can you give me some detail on how it did not work? What actually happened?

YL Yao Li
Yao Li
Member

  

Yellow Swordfish said
Can you give me some detail on how it did not work? What actually happened?  

Now I removed & deleted the simple press plugin in WP & file system, also I double checked the database. So it’s all cleaned up, I will do a clean install.

  1. Re-download the simple press core plugin for wordpress
  2. Unzip it, and upload it to /var/www/html/wp-content/plugins via WINSCP
  3. Go to WP Plugin page, activate simple press
  4. Click Install
  5. In the installation page, leave the two options checked, set the new WP page to “bbs“
  6. Click Perform Installation
  7. See snapshot1.png for the error message
  8. Click Go to Forum Admin
  9. See snapshot2.png for the error message, the current url is wp-admin/admin.php?page=simple-press/admin/panel-forums/spa-forums.php
  10. If I try to access it from the sidebar – Forum, I get the same error message. The url is wp-admin/admin.php?page=simple-press/sp-startup/sp-load-install.php
  11. Refresh the wp-admin page, then go into simple press from sidebar, see snapshot3.png.This is all I can see.

Some other information:

  • snapshot4.png, the capabilities of the current user 
  • snapshot5.png, the usermeta data of capabilities in database
  • Directories 755, files 644
snapshot1.pngsnapshot2.pngsnapshot3.pngsnapshot4.pngsnapshot5.png
YS Yellow Swordfish
Yellow Swordfish
Member

Well yes – if nothing changed I would expect the same result.

The important question was why did manually unzipping the folders not work. You just said it didn’t work. I was asking for a detailed explanation of what happened to try and determine why it didn’t work.

I.e., was there an error message in whatever tools you were using to unzip them?

I am trying to determine if this might genuinely be a UID/GUID issue. If it is, then you would need to ask your hosting support to correct the UID/GUIDs on the wp-content folder (and anywhere else needed) to allow for it to be owned by the ‘website’, UID/GUID settings on a folder determine the ownership. If not ‘owned’ by the ‘website’ then you would not be able to create folders within it – or at least programatically you would not be able to.

YL Yao Li
Yao Li
Member

Yellow Swordfish said
Well yes – if nothing changed I would expect the same result.

The important question was why did manually unzipping the folders not work. You just said it didn’t work. I was asking for a detailed explanation of what happened to try and determine why it didn’t work.

I.e., was there an error message in whatever tools you were using to unzip them?

I am trying to determine if this might genuinely be a UID/GUID issue. If it is, then you would need to ask your hosting support to correct the UID/GUIDs on the wp-content folder (and anywhere else needed) to allow for it to be owned by the ‘website’, UID/GUID settings on a folder determine the ownership. If not ‘owned’ by the ‘website’ then you would not be able to create folders within it – or at least programatically you would not be able to.  

The first time I installed the plugin via WP plugin upload. The second time I manually upload the plugin via SCP – I’ve tried re-installation 4 times but still getting the same error. 

There was no error/message when unzipping or uploading.

Really appreciate your help.

Yao

YS Yellow Swordfish
Yellow Swordfish
Member

Sorry – I understand all of this. The question I asked was regarding this statement:

I found the two zip files, and unzip them to the sp-resources directory. But it does not work…

did this mean that the manual unzip and install of the files did not work and – assuming this is what you mean – what exactly happened? What does ‘it does not work’ mean?

YL Yao Li
Yao Li
Member

I have a new found …I’m trying to install simple press via WP plugin upload.

After uploaded the plugin via web, I clicked the “Activate”, then I got an empty page with error message like “This plugin has no valid title”- The error message is Chinese so I simply translated it to English, 

snapshot-new.png

 

If I go back to the WP admin page then go to the plugin page, I still can activate the simple press plugin.

YL Yao Li
Yao Li
Member

Yellow Swordfish said
Sorry – I understand all of this. The question I asked was regarding this statement:

I found the two zip files, and unzip them to the sp-resources directory. But it does not work…

did this mean that the manual unzip and install of the files did not work and – assuming this is what you mean – what exactly happened? What does ‘it does not work’ mean?  

I followed your instruction, unzipped theme to the directory, but the simple press plugin still did not work. I got the same error as before.

Sorry for the vague description…

YS Yellow Swordfish
Yellow Swordfish
Member

“This plugin has no valid title”

Not even sure what this means. But whatever it means the plugin files are valid. Unless, of course, you for some reason have a corrupted version. But I don’t think anyone has reported a corruption occuring during download or upload since people used to use FileZilla, which seems to have fallen out of favour somewhat recently – which is good because it corrupted files!

I can only suggest – firstly – that you have a talk to your hosting support about the permissions, UID and GUID on your folders starting with wp-content. Something is clearly wrong with your environment and it needs putting right.

YL Yao Li
Yao Li
Member

Yellow Swordfish said

“This plugin has no valid title”

Not even sure what this means. But whatever it means the plugin files are valid. Unless, of course, you for some reason have a corrupted version. But I don’t think anyone has reported a corruption occuring during download or upload since people used to use FileZilla, which seems to have fallen out of favour somewhat recently – which is good because it corrupted files!

I can only suggest – firstly – that you have a talk to your hosting support about the permissions, UID and GUID on your folders starting with wp-content. Something is clearly wrong with your environment and it needs putting right.  

I own the server, can you tell me how to diagnose this – and how to make the modifications to the folders.

Thank you very much.

YL Yao Li
Yao Li
Member

Plus, I don’t think the files may have any corruption because I downloaded the plugin zip file, and upload it many times.

YS Yellow Swordfish
Yellow Swordfish
Member

Personally I have no idea how one checks and changes the ownerships but I will ask my colleague @mr-papa who at least knows a little more ‘server-speak’ than I do.

YL Yao Li
Yao Li
Member

Thank you! Looking forward to the solution…

Can’t wait to use simple press as my new forum solution.smile