Support Forum

Upgrade from 4.51 – V5 leaves forum inaccessible

DW David Walsh
David Walsh
Member

Hi there,

I’ve just upgraded from V4.51 up to the most recent version.

When I went into the site, I wasn’t able to get access, no matter what the permissions the have.  I’ve logged in with different membership levels with different roles, all with differing permissions, and it’s not working.

This is what I get:

I have tried to update the permissions on each of the roles, but that doesn’t work.

I’ve looked around the options, and I don’t know what’s the issue.

If you could let me know what I need to do, I’d appreciate it.  Members are paying for access, and it’s not available right now.

Thanks in advance,

David

—

9 Answers

New Answer

YS Yellow Swordfish
Yellow Swordfish
Member

First give this a try… go to the forum admin > toolbox > housekeeping and click on the option to rebuild the auths cache… See if that helps any.

MP Mr Papa
Mr Papa
Member

are there any errors in the error log? might check forum – toolbox – error log…

who see’s that screen?  admins? users? guests?  anyone or just specific ones?

can you take a look in the db, table sfauths… and look at the admin_negate column… how many are non zero?

DW David Walsh
David Walsh
Member

Hey there,

Everyone sees this right now.

Yeah, there are loads of errors in the error log, as it happens.  They are 99%:
—————————-

file: /simple-press/sp-api/sp-api-auths.php

line: 71

function: sp_rebuild_user_auths

Warning | Invalid argument supplied for foreach()

—————————-

and the other 1% is:

—————————-

file: /simple-press/sp-api/sp-api-auths.php
line: 71
function: Unavailable
Warning | Invalid argument supplied for foreach()

—————————-

The sfauths table is completely empty, so there’s nothing in the admin_negate field.

I’m guessing this isn’t a good thing.  Any way to fix this?

Thanks in advance,

David
—

MP Mr Papa
Mr Papa
Member

okay, drats… thats like 7th or 8th permission who lost permissions on upgrade (not too bad considering tens of thousands of upgrades, but still 7 or 8 more than we would like)…

so go to forum – permissions – reset permissions…  and go ahead and reset your permissions…

NOTE:  you will need to go back through your permissions and make any customizations you had made… 

sorry, for these handful, we have never been able to ascertain what is happening…

DS Donnie Schexnayder
Donnie Schexnayder
Member

FYI – I had the same problem. Resetting the permissions and then re-assigning them fixed it.

MB Matthew Bisogno
Matthew Bisogno
Member

Me too.

 

http://www.horseracingexperts.co.uk/forum/ 

DW David Walsh
David Walsh
Member

Yep, did that yesterday and it did help.  Thanks Mr Papa, it really helped :)

David
—

YS Yellow Swordfish
Yellow Swordfish
Member

Oh dear… a sudden epidemic!
It really has only been a small number of users so it is an odd little rash of them today!