Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
plugins-topic
Advert Plugin Not Allowing Shortcode
Avatar
Michael Wilding
Member
Free Members
sp_UserOfflineSmall Offline
Sep 18, 2019 - 8:15 am

I've tried putting in a Wordpress shortcode into the box from the ad plugin we use, but it doesn't work and just shows the shortcode. I don't have JS code, only PHP code as an alternative. Can I not use a wordpress shortcode or PHP code in the plugin? If so I may need to return it as I don't think I'll be able to use it.

Avatar
SP Community Support
SP Moderator
sp_UserOfflineSmall Offline
Sep 18, 2019 - 11:29 am

Hi:

Adverts don't take short-codes. It takes text and HTML or a JS script.

Avatar
Michael Wilding
Member
Free Members
sp_UserOfflineSmall Offline
Sep 19, 2019 - 8:16 am

Thank you. I've got it working now, but I can't get the before/after topics to work. The only one I can get to work is Above All Forums, none of the others seem to go in. What could be the cause of preventing that? The forum is at https://www.raceadvisor.co.uk/forum

Avatar
SP Community Support
SP Moderator
sp_UserOfflineSmall Offline
Sep 19, 2019 - 5:25 pm

Hi:

Its hard to tell why that might be without more context.  Maybe post screen shots of your settings for the ad group and the ads?  That might provide a clue as to what might be going on.

Thanks.

Avatar
Michael Wilding
Member
Free Members
sp_UserOfflineSmall Offline
Sep 21, 2019 - 6:43 am

That would help! I've attached two screenshots, both the ad and group are active. You can see that I've set the ad to show in four places, however it's only showing at the top of the forum, the first one.2019-09-21_1141.pngImage Enlarger2019-09-21_1142.pngImage Enlarger

Avatar
SP Community Support
SP Moderator
sp_UserOfflineSmall Offline
Sep 21, 2019 - 4:33 pm

What happens if you use a regular text/html ad instead of a JS ad?  Do those show up all four locations?

Thanks.

Avatar
Michael Wilding
Member
Free Members
sp_UserOfflineSmall Offline
Sep 23, 2019 - 4:33 pm

No, still only shows up at the top.

Avatar
SP Community Support
SP Moderator
sp_UserOfflineSmall Offline
Sep 23, 2019 - 4:54 pm

hmmm...I am out of ideas as to what might be causing the issue.  I just double-checked on our qa servers to verify that it does work and that we didn't somehow inadvertently break something.  As far as I can tell it works with the usual suspects of plugins installed (eg: wc and such).  There might be a plugin installed on your site or even a theme that is getting in the way of things.

But there might be a workaround.  Try creating ad-sets for each location.  So each adset would have one location instead of multiple and see if the ads show up in those locations then.

Thanks.

Avatar
Michael Wilding
Member
Free Members
sp_UserOfflineSmall Offline
Sep 24, 2019 - 4:28 am

Thanks

Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 649
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 618
Members: 17348
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10120
Posts: 79607