Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
plugins-topic
Embed Simple:Press
Avatar
Dave Downie
Member
Free Members
sp_UserOfflineSmall Offline
Sep 11, 2019 - 11:21 pm

I'm using Avada theme with Fusion Builder.

I'd like to put Simple:Press within a 3/4 page container.

I've tried many plugins in and different ways but it will not display the forum.

Even without Fusion Builder, using the default page editor, I can not embed it within a page.

Basically I want to embed the Simple: Press page in anther page.

I can't make it work with the 'Insert Pages' plugin, iframe, embed etc

Any help appreciated.

Thanks

Avatar
SP Community Support
SP Moderator
sp_UserOfflineSmall Offline
Sep 12, 2019 - 12:38 am

Hi:

The forum can only be displayed on the page designated in FORUM->INTEGRATION.  Simple:Press takes over the entire content area of that page.  This is similar to how popular plugins like WooCommerce works (The WooCommerce store will take over the entire content area of a page as well). 

In WordPress, the content area is the main area of the page.  There are other areas such as headers, footers and sidebars.  Your PAGE TEMPLATE control if and how these other areas show up on the page as well as the width of these areas.

Many themes provide more than one page template - for example themes might provide a full-width page template without sidebars and another that has side bars on both sides.  You can see your options directly on the page when you edit the pages directly from the WordPress PAGES list.

Sometimes, there is only one page template and you get options on the page or in the customizer that you can use to turn on/off the non-content areas. 

So, if you want to put the simple:press content into a 3/4 page container then your theme PAGE TEMPLATE must be 3/4 width for the main content area.  If you don't have one that has a 3/4 width for the content area then you'll need to get a developer to add that page template for you.

Thanks.

Avatar
Dave Downie
Member
Free Members
sp_UserOfflineSmall Offline
Sep 18, 2019 - 1:18 pm

Thank you. For the benefit of others in the future, I had a lot of errors using the Avada theme.

They were all related to page display, loosing formatting ect.

They all disappeared when I changed themes.

Avatar
Simple Press
Admin
sp_UserOfflineSmall Offline
Sep 18, 2019 - 1:48 pm

hmmm....that's interesting. I just quickly activated the Avada theme on our test site and it looks as if the forum page displays without errors.  I didn't spend too much time poking around but a quick activation and perusal of the forum page didn't reveal any of those kinds of errors. Avada is a HUGE theme though - one that goes way way overboard with their options to try to be all things to all users.  So its possibly a particular combination of non-default options that's triggering the issues you're seeing.  

Also, bootstrap components are loaded with Avada and they're not loaded in the correct order so you might have to comment out that script - see this forum post: https://simple-press.com/suppo.....p169209. 

Thanks.

Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 649
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 618
Members: 17348
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10120
Posts: 79605