Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
plugins-topic
Report Post: does not send the email bug
Avatar
Blaise F
Rookie
Pro Subscribers
sp_UserOfflineSmall Offline
Oct 30, 2019 - 11:24 am

Hi,

Report Post plugin stopped working about a month ago.

Short story: the bug is with the wp_mail function in sp-core-support-functions.php : this returns an error "Could not instantiate mail function".

Much longer story: Report Post works perfectly on my development site (dev.website.com) and not in production (website.com). Both are very very similar. The wp_mail function Simple Press calls is a standard WP function so why this does not work in production is a mystery to me.

To send emails I use Mailgun SMTP. I tried using Amazon SES and I get the same error.

wp_mail works perfectly in all other areas of my production site with both Mailgun and Amazon.

Simple Press sends emails correctly for instance for the Subscribe to post feature.

I have searched the internet for a solution to the "could not instantiate mail function". I suspect it must be a very specific server setting that blocks this but I'm at a loss.

Avatar
SP Community Support
SP Moderator
sp_UserOfflineSmall Offline
Oct 30, 2019 - 9:01 pm

That's a weird one.  Is the development site on the same server as the production site?

If not, then one thing to do would be to try to clone the production site to a new instance on the same server (most hosts can do this quickly) to see if the problem shows up on the cloned site.  When the site is cloned, usually you have a new instance of php configuration files so this is a good way to quickly find out if it is indeed a server issue that would affect all sites or if its just your one site that is being affected.

Also, what happens if you spin up a new clean site on the server and just install SP and the report post add-on.  Does that still show the error?

I assume you're using the latest versions of PHP and WP?

Thanks.

Avatar
Blaise F
Rookie
Pro Subscribers
sp_UserOfflineSmall Offline
Oct 31, 2019 - 2:40 pm

Hi,

Thank you for your answer.

I solved the issue in the strangest way: I disabled the Simple Press "File Uploader with plupload" in my production site. (V5.1.0). This plugin is still active on the dev platform.

This plugin was causing a more serious bug: when any user tried to click a button "reply" or "new post" nothing at all happened. It's after a few hours of searching and finally by disabling all plugins that I discovered the culprit.

But to be clear the plugin still works in DEV. It's something specific about my production environment. I can live without this plugin so I will not investigate the matter further.

Yes: it's the same server. Dev is just in dev.mywebsite.com

Everything is pretty much up to date:

SP 6.2.1

WP 5.2.4

PHP 7.3.11

mysql 5.5.5

 

Apart from that I must say the the upgrade documentation to V6 was great: thanks a lot!

Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 649
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 618
Members: 17348
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10120
Posts: 79607