Support Forum

Admins versus "Admin" User Group

< 1 2
jim
Here and Now
Member
Platinum Members
Mar 22, 2019 - 6:19 pm

Simple Press said
Open a ticket...add your credentials...make a video showing exactly what you're doing...

Working on that now, but I just figured out what's going on...

I'll need your team to figure out why, and develop a fix:

I can filter the list and add a user to the user group only if that user is not already a forum administrator.

Make that user and Admin, and he cannot be added. Remove forum administration capabilities, and the user can be added. Something is going on under the hood to prevent a user from being added to a group with capabilities similar that which the user has.

Please try to replicate while I get a screen capture together.

Thanks!

jim
Here and Now
Member
Platinum Members
Mar 22, 2019 - 6:55 pm

Simple Press said
...add your credentials for the site using the Private Credentials button.

I am not seeing this Private Credentials button anywhere after submitting a ticket.

Where do I submit credentials privately, this made me presume doing so via the ticket was not private.

jim
Here and Now
Member
Platinum Members
Mar 22, 2019 - 7:14 pm

Simple Press said
Open a ticket...

Please check your Private Messages. The ticket submission is not functioning properly (Firefox, Mac OS). See PM for details, video and credentials.

Simple Press
Admin
Mar 22, 2019 - 8:32 pm

Hi:

Thanks for the PM and the video. I thought you were doing something different so the video clarified some things.  What you're running into is a general Simple:Press restriction - Simple:Press admins cannot be added to groups.  There's no need - they have a different access process.  So once designated an admin they are bound by a different set of rules outside of group rules so it makes no sense to add them to groups.

If you try to add an admin to a group on a regular wp site (i.e.: not a multisite), you'll see the same thing.

I hope that makes sense.

Thanks.

jim
Here and Now
Member
Platinum Members
Mar 22, 2019 - 8:53 pm

Simple Press said
Simple:Press admins cannot be added to groups...I hope that makes sense.

Technically, yes.

I presume the reason Jerry was a member of our "Members" group is because he was a member before being made an SP Admin. He obviously retained that usergroup membership after being made an SP Admin, because he was listed in the group earlier today, then disappeared from the group when attempting to move him to the "Admin" usergroup.

So...

1. It sounds like you're telling me the only way to address the empty search results for the specific usergroup "Admin" is to delete that usergroup.

2. It would then seem the only way to assign a badge to forum admins would be to create a Special Rank, correct?

Thank you for the quick support, and confirming that this is actually expected behavior.

Simple Press
Admin
Mar 22, 2019 - 9:08 pm

Hi:

Yes, you can add special ranks to admins.  If you need a special badge for them then, yes, the special ranks are the way to go.

Thanks.

< 1 2