Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
general-topic
Custom Icons Folder
Avatar
jackey
Nederland
Member
Free Members
sp_UserOfflineSmall Offline
Sep 19, 2011 - 2:39 am

Where should the Custom Icons Folder reside? The path in the storage location does not exist (latest build).

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Sep 19, 2011 - 3:36 am

The first question has to be - have you activated the custom icon plugin (forum admin > Plugins)?

If you have then the default folder should appear in the Storage Locations list and the folder been created.

As to the actual question you asked - it really has three answers:

  1. If this is a new install of SP then the plugin activation will attempt to create the storage location under wp-content/sp-resources/
  2. If an upgrade from a previous V4 SP then the folder should already exist under wp-content and will remain there unless you checked the box at the first upgrade to V5 to move existing folders.
  3. And finally - of course - you can actually move or create the folder wherever you like as long as you match the Storage Location to the physical path.

If you HAVE activated the plugin and it still does not appear in the locations list then that would be a bug. So please do let us know.

andy-signature.png
YELLOW
SWORDFISH
Avatar
jackey
Nederland
Member
Free Members
sp_UserOfflineSmall Offline
Sep 19, 2011 - 3:45 am

No, it is not available...

Aha... this path was lost when I removed the 4.5 version "simple-forum". I presume the Custom Icon Plugin does not exist (yet).

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Sep 19, 2011 - 4:19 am

embarassed Scrap everything I just said. Well some of it anyway. Sorry - it is early here and I have a very busy day so my mind might be wandering! Custom Icons WERE going to be a plugin but we changed our mind. You will find it under the Forums menu list. The folder should have been created by the install under wp-content/sp-resources and there should be an entry in the storage locations.

So - did something go wrong and do we need to address something here? (And again apologies for my confusion)

andy-signature.png
YELLOW
SWORDFISH
Avatar
jackey
Nederland
Member
Free Members
sp_UserOfflineSmall Offline
Sep 19, 2011 - 4:30 am

The "storage locations" holds a path "plugins/simple-forum/styles/icons/default/custom" typical to the old version.

I can't find a similar path in sp-resources where "Custom Icons Folder" should point to.

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Sep 19, 2011 - 4:40 am

Was this a completely new installation or was this an upgrade from a V4.4.5 version?
And if it was completely new - had you had a version of SP before and if so - how did you remove it?

andy-signature.png
YELLOW
SWORDFISH
Avatar
jackey
Nederland
Member
Free Members
sp_UserOfflineSmall Offline
Sep 19, 2011 - 4:52 am

It was an upgrade from the V4.4.5 version... 

Removed the old (de-activated) plugin by deleting the old "simple-forum" folder from the plugin folder. (long after the upgrade was made) 

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Sep 19, 2011 - 9:09 pm

so if it was in default skin, you probably werent using any anyways??

and sorry, Andy but there is not a custom icon plugin... custom forum icons are still part of core...

in 5.0, by default they should be in wp-content/sp-resources/forum-custom-icons

we dont automatically change that location on an upgrade because there is no telling where users may have located at and what might be in there...

and as I said, in your case, you probably werent using it anyways, so no issue with the location not validating...

the upgrade should create the location that I said above though... so you should just be able to change it to that...

Avatar
jackey
Nederland
Member
Free Members
sp_UserOfflineSmall Offline
Sep 20, 2011 - 1:45 am

Clear!

Thanks!

I can't create the folder because I have no permission (it is owned by user 99). I presume it is created by SimplePress.
I've created the folder /wp-content/forum-custom-icons and assigned 777 permissions.

Avatar
Mr Papa
Simi Valley, CA
SP Master
Free Members
sp_UserOfflineSmall Offline
Sep 20, 2011 - 8:34 am

good to hear.  thanks for the update.

Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 647
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 616
Members: 17344
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10117
Posts: 79596