Support Forum

Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
general-topic
Is there a general cache stopping posts?
Avatar
dogsday
Member
Free Members
sp_UserOfflineSmall Offline
Aug 14, 2018 - 10:55 am

Hi there,

I'm almost embarassed to be asking this question, but it's been driving me nuts today trying to get past it so please put me out of my misery.

I've been testing the setup for threaded posts and am getting the situation where the poster is not seeing their comments in the thread until they log out and back in again, while a guest is seeing them immediately.

This can be seen in the two attachments where the Guest user is showing 8 Replies against a thread while a member is only showing 4. The test url for the thread is http://dailyphoto.co.uk/forum/.....-the-news/

I'm sure there must be a permissions setting somewhere, but can I find it..?

Thanks for your help

DD

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Aug 14, 2018 - 1:17 pm

Are you using a WP Cache plugin at all? If you are then you will need to set the forum page as an exception.

andy-signature.png
YELLOW
SWORDFISH
Avatar
dogsday
Member
Free Members
sp_UserOfflineSmall Offline
Aug 14, 2018 - 2:50 pm

WP Cache disabled and I'm testing through a Google incognito session.

Interestingly, possibly, having left the members browser open for an hour or so, the 'Replies' has updated, which does suggest a caching somewhere.

DD

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Aug 14, 2018 - 3:44 pm

Well deactivating WP Cache is not usually enough. You will also need to ensure the current cache is empty (which can be done via it's admin interface). Usually, however just emptying the current cache and ensuring all items of the cache options are set to ignore the base forum permalink - is enough to stop it coming into play.

The problem is that you can not cache a forum page. For starters all users may see different data depending on their permissions. Plus new data is being added all of the time so it needs to be kept current and immediate. Unlike a static blog post page, a forum is dynamic and changing all the time.

andy-signature.png
YELLOW
SWORDFISH
Avatar
dogsday
Member
Free Members
sp_UserOfflineSmall Offline
Aug 15, 2018 - 2:49 am

My error in explanation of WP Cache - I had deactivated it before installing SP as I realise that forum content is dynamic by nature.

I now seem to have it sorted after clearing down all browser history and cached files, resetting router, clearing WP Cache files and anything else that I could think of deleting.

Apologies for the diversion, borne out of frustration. You'll know how it is at times.

DD

Avatar
Yellow Swordfish
Glinton, England
SP Master
sp_UserOfflineSmall Offline
Aug 15, 2018 - 2:51 am

It's the cache files in the code that always have to be removed. Glad it is sorted.

andy-signature.png
YELLOW
SWORDFISH
Forum Timezone: Europe/Stockholm
Most Users Ever Online: 1170
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 639
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Member Stats:
Guest Posters: 616
Members: 17342
Moderators: 0
Admins: 4
Forum Stats:
Groups: 7
Forums: 17
Topics: 10116
Posts: 79581