A A A
Forum Scope


Match



Forum Options



Min search length: 3 characters / Max search length: 84 characters
Forum Login
Lost password?
general-topic
License Activation Failure
Avatar
jim
Here and Now

630 Posts
(Offline)
1
May 1, 2019 - 12:33 pm
Print

I noticed updates are available for a few plugins purchased via our Platinum bundle, but SimplePress add-on updates are no longer appearing on the Updates tab in our network dashboard.

FYI: This is a multisite network, and SimplePress is only active on the main site.

Understanding that Licensing has now been implemented for SimplePress plugins and themes, I checked the SP Licensing tab, but when attempting to save the license for our Platinum Bundle for any SP plugin, I get the error message: “Something went wrong.” I activated our site in our SimplPress account, and that made no difference.

No relative errors or warnings appear in the SP Error Log.

Please advise how we can get SP plugin update notifications to appear in our network dashboard again. I do not want to implement any automatic updates, but I do want to update plugins from our network dashboard like we always did – or have the ability to update them from the site’s Forum Dashboard tabs. We use far too many plugins to download and update via FTP all the time.

NOTE: Clicking the View Version Details for any SP plugin update, loads the wp-admin/network/plugin-install page in the pop-up window, with no information about SimplePress plugins.

Thank you.

Screen-Shot-2019-05-01-at-9.57.37-AM.pngImage Enlarger

sp-plugin-popup.pngImage Enlarger

TripawdsSimple:Press powers the Tripawds Discussion Forums.

It's better to hop on three legs than to limp on four.

The Tripawds Blogs Community is made possible by The Tripawds Foundation.

Avatar
Simple Press
389 Posts
(Offline)
2
May 1, 2019 - 1:35 pm
Print

Hi:

We’ll need to log into your site to take a look at this.  I suspect that the new licensing code from our ecommerce licensing system might not work with multisite but we’ll need to log in to check.  We’ll need wp-admin and ftp credentials.  There are three ways to get this to us:

1. Send me a PM via this forum

2. Make a private post in this thread or 

3. Open a private ticket and then, look for the Private Credentials button

Also, have you tried the process without any caching or cdn?

Thanks.

Building out your membership site can be a lot of work. Easy Membership Sites has pre-configured all the Simple:Press plugins and tools you need to build a complete membership site in a fraction of the usual time. Check them out: Easy Membership Sites

Avatar
jim
Here and Now

630 Posts
(Offline)
3
May 3, 2019 - 10:36 am
Print

Simple Press said
have you tried the process without any caching or cdn?

I have not, and I’d really rather not turn these off after all of the optimization tweaks we have made recently. Please advise if you have a multisite environment for testing, and I’ll send credentials via PM if necessary.

Will my license work on our staging domain, if that domain is not added in my SP account?

TripawdsSimple:Press powers the Tripawds Discussion Forums.

It's better to hop on three legs than to limp on four.

The Tripawds Blogs Community is made possible by The Tripawds Foundation.

Avatar
jim
Here and Now

630 Posts
(Offline)
4
May 3, 2019 - 10:44 am
Print

jim said
Will my license work on our staging domain, if that domain is not added in my SP account?

I see that the license can only be activated on one site, even with the Platinum Bundle!?

A license cannot also be used in a staging environment? Something to consider…

TripawdsSimple:Press powers the Tripawds Discussion Forums.

It's better to hop on three legs than to limp on four.

The Tripawds Blogs Community is made possible by The Tripawds Foundation.

Avatar
Simple Press
389 Posts
(Offline)
5
May 3, 2019 - 3:08 pm
Print

Hi:

Yeah, we really need to be able to turn off some of these things for troubleshooting.  WordPress is great in that it offers so many options for anything you want. But that flexibility is also its greatest weakness because things conflict.  90% of the time we find that its a conflict somewhere that causes an issue – so when we troubleshoot things we haven’t seen before deactivating things that aren’t published by us is the first thing we have to do otherwise we’re likely to be spinning our wheels.  However, if you have a staging environment we can definitely troubleshoot there first.  We can attempt to activate the license there to see if the issue presents itself and, if so we can figure out how to resolve it there.  Once resolved we can deactivate the license and activate on your live site.

re: platinum bundle – that is licensed on a per-site basis just like all the other bundles.  

Usually there is no need to activate a license on a test or staging site. But you can do that then deactivate it and activate on your live site when you are ready.  You can deactivate licenses on your account screen on simple-press.com or do it inside the license screen in the wp-admin area on your site.

Thanks.

Building out your membership site can be a lot of work. Easy Membership Sites has pre-configured all the Simple:Press plugins and tools you need to build a complete membership site in a fraction of the usual time. Check them out: Easy Membership Sites

Avatar
jim
Here and Now

630 Posts
(Offline)
6
May 15, 2019 - 7:05 pm
Print

After deactivating our site then reactivating it in my SP account, I was able to update a few SP plugins from the network updates admin page.

Most recently, I was able to updates Subscriptions today, after adding the license key yesterday. (I could not update it immediately after doing so.)

The Search plugin, however, still fails to update, even after “successful” update…the plugin update process completes, but the plugin remains on the Updates page.

I think something else is going on. It seems odd that the plugin suggests to update from version 2.1 to version 2.1.0.

search-updated.pngImage Enlarger

search-update.pngImage Enlarger

subs-updated.pngImage Enlarger

Attachments

TripawdsSimple:Press powers the Tripawds Discussion Forums.

It's better to hop on three legs than to limp on four.

The Tripawds Blogs Community is made possible by The Tripawds Foundation.

Avatar
jim
Here and Now

630 Posts
(Offline)
7
May 15, 2019 - 7:11 pm
Print

FYI: Issue persists with updating the Search plugin even after manual update.

I downloaded Search version 2.1.0 from my SP account, updated via FTP, and the Updates page still says version 2.1, as does the plugin file, and changelog…

Screen-Shot-2019-05-15-at-5.08.55-PM.pngImage EnlargerScreen-Shot-2019-05-15-at-5.10.45-PM.pngImage Enlarger

TripawdsSimple:Press powers the Tripawds Discussion Forums.

It's better to hop on three legs than to limp on four.

The Tripawds Blogs Community is made possible by The Tripawds Foundation.

Avatar
Simple Press
389 Posts
(Offline)
8
May 16, 2019 - 12:47 pm
Print

Hmmm….that looks like we made a mistake with the version number when updating our licensing system.  We updated more than 70 items for the 6.1 release so I guess its no surprise one slipped through the cracks.  We just revised the version number for search to 2.3.0.  That should show up within the next 24 hours on your system or you can force it on the LICENSE screen by clicking the CHECK FOR UPDATES NOW button.

Building out your membership site can be a lot of work. Easy Membership Sites has pre-configured all the Simple:Press plugins and tools you need to build a complete membership site in a fraction of the usual time. Check them out: Easy Membership Sites

Avatar
jim
Here and Now

630 Posts
(Offline)
9
May 16, 2019 - 1:12 pm
Print

Simple Press said
We just revised the version number for search to 2.3.0….you can force it on the LICENSE screen

That did the trick, thanks.

I added our license to all SP plugins and themes, and kept getting the notice “Something went wrong…”* but the keys stuck.

I notice a new Reboot is available. Were there any template changes? I’m not finding anything about this upgrade in the docs – but then I only see theme and template changes going up to 6.0.

 

*These look unrelated, but they are the only error log entries today. Only the latter has a timestamp approximate to when I was updating the licenses …

 

16 May 2019 1:51 am | spaErrWarning | 17350 | php


file: /simplepress/sp-api/sp-api-class-spcfilters.php
line: 135
function: preg_match_all
Warning | preg_match_all(): Compilation failed: invalid UTF-8 string at offset 41

 

16 May 2019 10:59 am | spaErrError | 31 | database


file: /home/tripawds/public_html/wp-content/plugins/simplepress/sp-api/sp-api-class-spcoptions.php
line: 101
function: insert
error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘s Posts<\\\/p>\
\\\”;s:9:\\\”changelog\\\”;s:136:\\\”

Version 2.0.0<\\\/p>\
‘ at line 1

INSERT INTO wp_1_sfoptions (option_name, option_value) VALUES (‘spl_plugin_versioninfo_3916’, ‘{“new_version”:”2.0.0″,”stable_version”:”2.0.0″,”name”:”post-ratings”,”slug”:”post-ratings-plugin”,”url”:”https:\/\/simple-press.com\/downloads\/post-ratings-plugin\/?changelog=1″,”homepage”:”https:\/\/simple-press.com\/downloads\/post-ratings-plugin\/”,”last_updated”:”2018-11-17 17:02:31″,”download_link”:””,”package”:””,”icons”:”\”a:2:{s:2:\\\”1x\\\”;s:72:\\\”https:\\\/\\\/simple-press.com\\\/wp-content\\\/uploads\\\/edd\\\/2015\\\/04\\\/post-ratings.png\\\”;s:2:\\\”2x\\\”;s:72:\\\”https:\\\/\\\/simple-press.com\\\/wp-content\\\/uploads\\\/edd\\\/2015\\\/04\\\/post-ratings.png\\\”;}\””,”banners”:”\”a:2:{s:4:\\\”high\\\”;s:0:\\\”\\\”;s:3:\\\”low\\\”;s:0:\\\”\\\”;}\””,”sections”:”\”a:2:{s:11:\\\”description\\\”;s:55:\\\”

Give your Users the power to Rate other’s Posts<\\\/p>\
\\\”;s:9:\\\”changelog\\\”;s:136:\\\”

Version 2.0.0<\\\/p>\

    \
  • Added: Simple:Press 6.0 compatibility<\\\/li>\
    <\\\/ul>\

    Version 1.0.0<\\\/p>\

      \
    • Initial Release<\\\/li>\
      <\\\/ul>\
      \\\”;}\””}’) ON DUPLICATE KEY UPDATE option_name = (‘spl_plugin_versioninfo_3916’), option_value = (‘{“new_version”:”2.0.0″,”stable_version”:”2.0.0″,”name”:”post-ratings”,”slug”:”post-ratings-plugin”,”url”:”https:\/\/simple-press.com\/downloads\/post-ratings-plugin\/?changelog=1″,”homepage”:”https:\/\/simple-press.com\/downloads\/post-ratings-plugin\/”,”last_updated”:”2018-11-17 17:02:31″,”download_link”:””,”package”:””,”icons”:”\”a:2:{s:2:\\\”1x\\\”;s:72:\\\”https:\\\/\\\/simple-press.com\\\/wp-content\\\/uploads\\\/edd\\\/2015\\\/04\\\/post-ratings.png\\\”;s:2:\\\”2x\\\”;s:72:\\\”https:\\\/\\\/simple-press.com\\\/wp-content\\\/uploads\\\/edd\\\/2015\\\/04\\\/post-ratings.png\\\”;}\””,”banners”:”\”a:2:{s:4:\\\”high\\\”;s:0:\\\”\\\”;s:3:\\\”low\\\”;s:0:\\\”\\\”;}\””,”sections”:”\”a:2:{s:11:\\\”description\\\”;s:55:\\\”
      Give your Users the power to Rate other’s Posts<\\\/p>\
      \\\”;s:9:\\\”changelog\\\”;s:136:\\\”

      Version 2.0.0<\\\/p>\

        \
      • Added: Simple:Press 6.0 compatibility<\\\/li>\
        <\\\/ul>\

        Version 1.0.0<\\\/p>\

          \
        • Initial Release<\\\/li>\
          <\\\/ul>\
          \\\”;}\””}’)

TripawdsSimple:Press powers the Tripawds Discussion Forums.

It's better to hop on three legs than to limp on four.

The Tripawds Blogs Community is made possible by The Tripawds Foundation.

Avatar
Simple Press
389 Posts
(Offline)
10
May 16, 2019 - 1:33 pm
Print

Hi:

The ‘something went wrong’ issue is likely a timing thing – 6.1 only waited a short period of time before timing out the license verification.  6.2 increased that timeout. You can find that fix here on github now: https://github.com/Simple-Pres…..cc342703cf 

The REBOOT theme update added new template tags for new addons (Push notifications, Canned Replies).

Not sure what’s going on with the last item.  I don’t see that in any of our error logs right now but I’ll keep an eye out to see if anyone reports it.  It looks like its complaining on a single quote in the Excerpt for the plugin.  To test that theory I removed the single quote from the excerpt.  If the theory is correct you should no longer see that message in your logs going forward.

Thanks.

Building out your membership site can be a lot of work. Easy Membership Sites has pre-configured all the Simple:Press plugins and tools you need to build a complete membership site in a fraction of the usual time. Check them out: Easy Membership Sites

Forum Timezone: America/New_York
All RSSShow Stats
Administrators: Blues Dancer, Simple Press, SP Community Support
Top Posters:
Mr Papa: 19448
Ike: 2086
Brandon: 864
kvr28: 804
jim: 630
FidoSysop: 577
Conrad_Farlow: 531
fiddlerman: 358
Stefano Prete: 325
Newest Members:
James Smith
Martin Brothers
Arti Singh
Abdulaziz alghthbar
Tim Castillo
Kaspalita Thompson
Martin Kolář
Forum Stats:
Groups: 7
Forums: 17
Topics: 10059
Posts: 79348

 

Member Stats:
Guest Posters: 607
Members: 16900
Moderators: 0
Admins: 3

Most Users Ever Online
499
Currently Online
Guest(s)
23
Currently Browsing this Page

1 Guest(s)